summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2015-06-14 12:10:17 +0800
committerDario Giovannetti2015-06-14 12:10:17 +0800
commit2c803e82be56cf190f78c4e61ccdb6f31b6c741f (patch)
treecda5c9c6666e97b5edc16e083377ff20183a49f8
downloadaur-2c803e82be56cf190f78c4e61ccdb6f31b6c741f.tar.gz
Init commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD17
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aea2e48efd79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-texthistory
+ pkgdesc = Python undo/redo engine for plain text and wxPython TextCtrl
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/kynikos/lib.py.text-history
+ arch = any
+ license = GPL3
+ depends = python
+ source = http://downloads.sourceforge.net/project/kynikos/lib.py.text-history/python-texthistory-1.0.1.tar.bz2
+ sha256sums = 201b88b662e6d5392fabd063eedd3a9297b0215c8d7e2690b5fd00431e147eab
+
+pkgname = python-texthistory
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..397673978cc2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/python-texthistory
+/*.pkg.tar.xz
+/*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c134c078eac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='python-texthistory'
+pkgver='1.0.1'
+pkgrel=1
+pkgdesc="Python undo/redo engine for plain text and wxPython TextCtrl"
+arch=('any')
+url="https://github.com/kynikos/lib.py.text-history"
+license=('GPL3')
+depends=('python')
+source=("http://downloads.sourceforge.net/project/kynikos/lib.py.text-history/$pkgname-$pkgver.tar.bz2")
+sha256sums=('201b88b662e6d5392fabd063eedd3a9297b0215c8d7e2690b5fd00431e147eab')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}