summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-11-11 12:33:03 -0500
committerCarlos Aznarán2023-11-11 12:33:03 -0500
commit6978d05c46356c9832077cdc8b3bcb45e6501d5c (patch)
treeb8b88d948a283ae226d6497a2c8791c6cf589f85
parente6b0e252439294bcb9af2c11576d506aca29a49b (diff)
downloadaur-6978d05c46356c9832077cdc8b3bcb45e6501d5c.tar.gz
Add checkdependency
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0c8aca8794c..036e2e9eef1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = python-textual
checkdepends = python-pytest-asyncio
checkdepends = python-pytest-aiohttp
checkdepends = python-time-machine
+ checkdepends = python-tree-sitter-languages
makedepends = python-build
makedepends = python-installer
makedepends = python-poetry-core
diff --git a/PKGBUILD b/PKGBUILD
index 9a9ca4cbe16f..e5494d267283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url="https://github.com/Textualize/${_base}"
license=(MIT)
depends=(python-rich python-importlib-metadata python-typing_extensions)
makedepends=(python-build python-installer python-poetry-core)
-checkdepends=(python-pytest-asyncio python-pytest-aiohttp python-time-machine)
+checkdepends=(python-pytest-asyncio python-pytest-aiohttp python-time-machine python-tree-sitter-languages)
optdepends=('python-tree-sitter: for syntax highlighting support'
'python-tree-sitter-languages: for custom languages support')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)