summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-10-12 23:47:08 +0200
committerJose Riha2021-10-12 23:47:08 +0200
commite14a5d7e82ddff18d2bba1d73f2b06ce53b91fda (patch)
tree909dd7eea180449289b848fd97988dc48968ea37
downloadaur-e14a5d7e82ddff18d2bba1d73f2b06ce53b91fda.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c9a44b8c182
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-textual
+ pkgdesc = TUI (Text User Interface) framework for Python inspired by modern web development.
+ pkgver = 0.1.11
+ pkgrel = 1
+ url = https://github.com/willmcgugan/textual
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ makedepends = python-poetry
+ depends = python-rich
+ depends = python-pyfiglet
+ source = https://github.com/willmcgugan/textual/archive/v0.1.11/textual-0.1.11.tar.gz
+ md5sums = 50a91bd4519dcffd00d3bb48d2e1da54
+
+pkgname = python-textual
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68d92db0f946
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jose Riha <jose 1711 gmail com>
+
+pkgname=python-textual
+pkgver=0.1.11
+pkgrel=1
+pkgdesc='TUI (Text User Interface) framework for Python inspired by modern web development.'
+arch=(any)
+url='https://github.com/willmcgugan/textual'
+license=('MIT')
+depends=('python-rich' 'python-pyfiglet')
+makedepends=('python-pip' 'python-poetry')
+source=("https://github.com/willmcgugan/textual/archive/v${pkgver}/textual-${pkgver}.tar.gz")
+md5sums=('50a91bd4519dcffd00d3bb48d2e1da54')
+
+build() {
+ cd textual-${pkgver}
+ poetry build --format wheel
+}
+
+package() {
+ cd textual-${pkgver}
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}