summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-11-11 12:10:35 -0500
committerCarlos Aznarán2023-11-11 12:10:35 -0500
commite6b0e252439294bcb9af2c11576d506aca29a49b (patch)
tree9131eedc12a79f31cd7d2a7c9ecc84cfaf94a150
parent59134d29f72f4387e867f50f437a94ed2d92dcf2 (diff)
downloadaur-e6b0e252439294bcb9af2c11576d506aca29a49b.tar.gz
Bump version to 0.41.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fb2c07c0d87..e0c8aca8794c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-textual
pkgdesc = Modern Text User Interface framework
- pkgver = 0.40.0
+ pkgver = 0.41.0
pkgrel = 1
url = https://github.com/Textualize/textual
arch = any
@@ -14,8 +14,9 @@ pkgbase = python-textual
depends = python-rich
depends = python-importlib-metadata
depends = python-typing_extensions
- depends = python-tree-sitter-languages
- source = textual-0.40.0.tar.gz::https://github.com/Textualize/textual/archive/v0.40.0.tar.gz
- sha512sums = 7d69c4407f2bb97fc21e8c7b46756c172341cc6067178b06a6b0e3ea6e74ce929b250e40cf6737c01a2f317befda76830dcd9ca1e64c621cb4bed25123f6d07e
+ optdepends = python-tree-sitter: for syntax highlighting support
+ optdepends = python-tree-sitter-languages: for custom languages support
+ source = textual-0.41.0.tar.gz::https://github.com/Textualize/textual/archive/v0.41.0.tar.gz
+ sha512sums = 754e394b77cb0bb0246f288d2ef5efd9de63189f35076a8e6061e209c3efc30fa3bb24f4b5f4c0e34c3c91b325449cefe13db5cca144ea690d80c7bff8cea617
pkgname = python-textual
diff --git a/PKGBUILD b/PKGBUILD
index fcd6fff285ba..9a9ca4cbe16f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=textual
pkgname=python-${_base}
-pkgver=0.40.0
+pkgver=0.41.0
pkgrel=1
pkgdesc="Modern Text User Interface framework"
arch=(any)
url="https://github.com/Textualize/${_base}"
license=(MIT)
-depends=(python-rich python-importlib-metadata python-typing_extensions python-tree-sitter-languages)
+depends=(python-rich python-importlib-metadata python-typing_extensions)
makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest-asyncio python-pytest-aiohttp python-time-machine)
+optdepends=('python-tree-sitter: for syntax highlighting support'
+ 'python-tree-sitter-languages: for custom languages support')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('7d69c4407f2bb97fc21e8c7b46756c172341cc6067178b06a6b0e3ea6e74ce929b250e40cf6737c01a2f317befda76830dcd9ca1e64c621cb4bed25123f6d07e')
+sha512sums=('754e394b77cb0bb0246f288d2ef5efd9de63189f35076a8e6061e209c3efc30fa3bb24f4b5f4c0e34c3c91b325449cefe13db5cca144ea690d80c7bff8cea617')
build() {
cd ${_base}-${pkgver}