summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dejanovic2016-06-12 12:50:06 +0200
committerIgor Dejanovic2016-06-12 12:50:06 +0200
commit26a36d887d364ed51b72af11287741143854de54 (patch)
treed2f90c398f403c3ea56e601b9409f3823ce7888c
downloadaur-26a36d887d364ed51b72af11287741143854de54.tar.gz
Initial.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b5326854362
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-textx
+ pkgdesc = Python library for building Domain-Specific Languages and parsers
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://igordejanovic.net/textX/
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/igordejanovic/textX/archive/v1.4.tar.gz
+ md5sums = cb3de639d0150a044368041c5808d88e
+
+pkgname = python-textx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4dd43f542a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=python-textx
+_srcname=textX
+pkgver=1.4
+pkgrel=1
+pkgdesc="Python library for building Domain-Specific Languages and parsers"
+arch=('any')
+url="http://igordejanovic.net/textX/"
+license=('MIT')
+depends=('python')
+source=(https://github.com/igordejanovic/$_srcname/archive/v$pkgver.tar.gz)
+md5sums=('cb3de639d0150a044368041c5808d88e')
+
+package() {
+ cd "$srcdir/$_srcname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: