summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-09-28 16:09:33 +0200
committerIgor Dejanovic2020-10-03 19:23:03 +0200
commit53d64089a0c9beb663dc4d88ddd3105fe4d1572e (patch)
treeafeba9bf885bb39541557b5aa82ff3f874836cef
parent51bafeb29077157a8abce12a8f21917346c26521 (diff)
downloadaur-53d64089a0c9beb663dc4d88ddd3105fe4d1572e.tar.gz
Deduplicate pip calls in installation of test deps
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d34034edb262..f2cf7e38d6f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,12 +26,15 @@ check() {
export PYTHONUSERBASE="$tmpdir"
# Install all tests projects
- pip install --user -e . || exit 1
- pip install --user -e tests/functional/subcommands/example_project || exit 1
- pip install --user -e tests/functional/registration/projects/types_dsl || exit 1
- pip install --user -e tests/functional/registration/projects/data_dsl || exit 1
- pip install --user -e tests/functional/registration/projects/flow_dsl || exit 1
- pip install --user -e tests/functional/registration/projects/flow_codegen || exit 1
+ prjs=(.
+ tests/functional/subcommands/example_project
+ tests/functional/registration/projects/types_dsl
+ tests/functional/registration/projects/data_dsl
+ tests/functional/registration/projects/flow_dsl
+ tests/functional/registration/projects/flow_codegen)
+ for prj in "${prjs[@]}"; do
+ pip install --user -e "$prj" || exit 1
+ done
# Run all tests
PATH="$tmpdir/bin:$PATH" pytest --ignore tests/perf