summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsfmajors3732019-06-29 05:35:30 -0400
committersfmajors3732019-06-29 05:35:30 -0400
commit1a60e43893f014773557f808e631762fb08447eb (patch)
tree01f33f20ea380d15fa3fff9371a143f84d70b92b
downloadaur-1a60e43893f014773557f808e631762fb08447eb.tar.gz
Created tf-encryption using pipman-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06e3aaaba2ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-tf-encrypted
+ pkgdesc = A Framework for Machine Learning on Encrypted Data.
+ pkgver = 0.5.6
+ pkgrel = 1
+ url = https://github.com/tf-encrypted/tf-encrypted
+ arch = any
+ license = Apache
+ license = License
+ license = 2.0
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-tf-encrypted
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78f43cb70ea2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: The TF Encrypted Authors <tfencrypted@gmail.com>
+pkgname=python-tf-encrypted
+pkgver=0.5.6
+pkgrel=1
+pkgdesc="A Framework for Machine Learning on Encrypted Data."
+arch=(any)
+url="https://github.com/tf-encrypted/tf-encrypted"
+license=(Apache License 2.0)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="tf-encrypted" tf-encrypted==0.5.6
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/tf-encrypted/* $pkgdir/"$sitepackages"
+} \ No newline at end of file