summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-09-29 18:45:43 +0800
committerChih-Hsuan Yen2022-09-29 18:45:43 +0800
commit411f407f349c7dafc6e6e4c89fac31ace18896ec (patch)
tree7e4eeb982adf23a58eb5e664b0e8ee5abafcc4d9
parentf430068b0030ae4ce65da6ac9abcaf3c96c67502 (diff)
downloadaur-411f407f349c7dafc6e6e4c89fac31ace18896ec.tar.gz
unpin flatbuffers and update deps
See: https://github.com/google/flatbuffers/issues/7499
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fa6bd0c6fc9..72300ad933cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-tf2onnx
pkgdesc = Convert TensorFlow models to ONNX
pkgver = 1.12.1
- pkgrel = 1
+ pkgrel = 3
epoch = 1
url = https://github.com/onnx/tensorflow-onnx
arch = any
@@ -21,6 +21,7 @@ pkgbase = python-tf2onnx
depends = python-onnx
depends = python-requests
depends = python-six
+ depends = python-flatbuffers
source = https://github.com/onnx/tensorflow-onnx/archive/v1.12.1/tf2onnx-v1.12.1.tar.gz
source = onnxruntime.diff
sha256sums = 77529a4eaa6d50a572020a023af93047b942fbde5cf4447878014037481b7f5f
diff --git a/PKGBUILD b/PKGBUILD
index cfb5b6b1de9c..e5129c6ce83c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=python-tf2onnx
epoch=1
pkgver=1.12.1
-pkgrel=1
+pkgrel=3
pkgdesc='Convert TensorFlow models to ONNX'
arch=(any)
url='https://github.com/onnx/tensorflow-onnx'
license=(MIT)
-depends=(python python-tensorflow python-numpy python-onnx python-requests python-six)
+depends=(python python-tensorflow python-numpy python-onnx python-requests python-six python-flatbuffers)
makedepends=(python-setuptools python-build python-installer python-wheel)
checkdepends=(python-pytest python-graphviz python-parameterized python-yaml python-onnxruntime)
source=("https://github.com/onnx/tensorflow-onnx/archive/v$pkgver/tf2onnx-v$pkgver.tar.gz"
@@ -22,6 +22,9 @@ prepare() {
sed -i -r 's#--cov\S+##' setup.cfg
sed -i "s#'pytest-runner'##" setup.py
+ # https://github.com/onnx/tensorflow-onnx/issues/1977
+ sed -i 's#flatbuffers~=1.12#flatbuffers#' setup.py
+
# The latest upstream tag may not sync with the version file
echo $pkgver > VERSION_NUMBER