summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-08-27 15:07:12 +0800
committerlilac2021-08-27 15:07:12 +0800
commit933a5a86eae47e5d19646730b7a650cc5a98d2f3 (patch)
treeccb12ff9895de6c66704f1c3eed84a1ae79b26e5
parent8b38524be591fb6cf11c6372f9d2575b8ea5a9e9 (diff)
downloadaur-933a5a86eae47e5d19646730b7a650cc5a98d2f3.tar.gz
[lilac] updated to 1.9.2-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--larger-tolerance.diff31
3 files changed, 6 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ead537e6a0..d0ff665b0543 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tf2onnx
pkgdesc = Convert TensorFlow models to ONNX
- pkgver = 1.9.1
+ pkgver = 1.9.2
pkgrel = 2
url = https://github.com/onnx/tensorflow-onnx
arch = any
@@ -20,9 +20,7 @@ pkgbase = python-tf2onnx
depends = python-onnx
depends = python-requests
depends = python-six
- source = https://github.com/onnx/tensorflow-onnx/archive/v1.9.1/tf2onnx-v1.9.1.tar.gz
- source = larger-tolerance.diff
- sha256sums = e3bb05f0a2d0afe4d4bda4946bd04d0262dc7780a93e0ab5c9a5050f905ca869
- sha256sums = 171684b938833d544e04fef6a420ca209a4785b40377b99c8a37336bada5d3f1
+ source = https://github.com/onnx/tensorflow-onnx/archive/v1.9.2/tf2onnx-v1.9.2.tar.gz
+ sha256sums = 3abeb0014563b93f12bb39e403d8c08b68fc421589e8c46f450cb828d4aa6d07
pkgname = python-tf2onnx
diff --git a/PKGBUILD b/PKGBUILD
index b092839769ae..f64a91660e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
pkgname=python-tf2onnx
-pkgver=1.9.1
+pkgver=1.9.2
pkgrel=2
pkgdesc='Convert TensorFlow models to ONNX'
arch=(any)
@@ -10,16 +10,13 @@ license=(MIT)
depends=(python python-tensorflow python-numpy python-onnx python-requests python-six)
makedepends=(python-setuptools python-build python-install python-wheel)
checkdepends=(python-pytest python-graphviz python-parameterized python-yaml python-onnxruntime)
-source=("https://github.com/onnx/tensorflow-onnx/archive/v$pkgver/tf2onnx-v$pkgver.tar.gz"
- 'larger-tolerance.diff')
-sha256sums=('e3bb05f0a2d0afe4d4bda4946bd04d0262dc7780a93e0ab5c9a5050f905ca869'
- '171684b938833d544e04fef6a420ca209a4785b40377b99c8a37336bada5d3f1')
+source=("https://github.com/onnx/tensorflow-onnx/archive/v$pkgver/tf2onnx-v$pkgver.tar.gz")
+sha256sums=('3abeb0014563b93f12bb39e403d8c08b68fc421589e8c46f450cb828d4aa6d07')
prepare() {
cd tensorflow-onnx-$pkgver
sed -i -r 's#--cov\S+##' setup.cfg
sed -i "s#'pytest-runner'##" setup.py
- patch -Np1 -i ../larger-tolerance.diff
}
build() {
diff --git a/larger-tolerance.diff b/larger-tolerance.diff
deleted file mode 100644
index dc41766e9aa8..000000000000
--- a/larger-tolerance.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/tests/test_backend.py b/tests/test_backend.py
-index 36e27d1..8881715 100644
---- a/tests/test_backend.py
-+++ b/tests/test_backend.py
-@@ -432,7 +432,7 @@ class BackendTests(Tf2OnnxBackendTestBase):
- strides = [1, 2, 2, 1]
- x_val = np.arange(1, 1 + np.prod(x_shape)).astype("float32").reshape(x_shape)
- kernel_val = np.arange(1, 1 + np.prod(kernel_shape)).astype("float32").reshape(kernel_shape)
-- self._conv_test(x_val, kernel_val, strides=strides, padding="VALID", rtol=1e-05)
-+ self._conv_test(x_val, kernel_val, strides=strides, padding="VALID", rtol=1.1e-05)
-
- @check_tf_min_version("1.14", "tf 1.14 needed for explicit padding")
- def test_conv2d_explicit_padding(self):
-@@ -442,7 +442,7 @@ class BackendTests(Tf2OnnxBackendTestBase):
- strides = [1, 1, 1, 1]
- x_val = np.arange(1, 1 + np.prod(x_shape)).astype("float32").reshape(x_shape)
- kernel_val = np.arange(1, 1 + np.prod(kernel_shape)).astype("float32").reshape(kernel_shape)
-- self._conv_test(x_val, kernel_val, strides=strides, padding=pads, rtol=1e-05)
-+ self._conv_test(x_val, kernel_val, strides=strides, padding=pads, rtol=1.1e-05)
-
- def test_conv2d_dilation_same(self):
- x_shape = [1, 35, 35, 288] # NHWC
-@@ -451,7 +451,7 @@ class BackendTests(Tf2OnnxBackendTestBase):
- dilations = [1, 3, 1, 1] # NHWC
- x_val = np.arange(1, 1 + np.prod(x_shape)).astype("float32").reshape(x_shape)
- kernel_val = np.arange(1, 1 + np.prod(kernel_shape)).astype("float32").reshape(kernel_shape)
-- self._conv_test(x_val, kernel_val, strides=strides, padding="SAME", dilations=dilations, rtol=1e-05)
-+ self._conv_test(x_val, kernel_val, strides=strides, padding="SAME", dilations=dilations, rtol=1.1e-05)
-
- def test_conv2d_dilation_strides_same(self):
- x_shape = [1, 35, 35, 288] # NHWC