summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-09-22 10:57:19 +0800
committerChih-Hsuan Yen2022-09-22 10:57:19 +0800
commitf430068b0030ae4ce65da6ac9abcaf3c96c67502 (patch)
treee47c854b28f8b4031730eea20f99bd948a9b74c2
parent79e28b83b3724d550532582194df62eed93588fb (diff)
downloadaur-f430068b0030ae4ce65da6ac9abcaf3c96c67502.tar.gz
update to 1.12.1
* Reverts most changes in the previous commit after upstream switches back to a common tag pattern * Skips a test broken with TensorFlow 2.10
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3280381c7a24..1fa6bd0c6fc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-tf2onnx
pkgdesc = Convert TensorFlow models to ONNX
- pkgver = 1.12.0
- pkgrel = 2
+ pkgver = 1.12.1
+ pkgrel = 1
epoch = 1
url = https://github.com/onnx/tensorflow-onnx
arch = any
@@ -21,9 +21,9 @@ pkgbase = python-tf2onnx
depends = python-onnx
depends = python-requests
depends = python-six
- source = https://github.com/onnx/tensorflow-onnx/archive/v.1.12.0/tf2onnx-v1.12.0.tar.gz
+ source = https://github.com/onnx/tensorflow-onnx/archive/v1.12.1/tf2onnx-v1.12.1.tar.gz
source = onnxruntime.diff
- sha256sums = 958c1bd50131e91d91a79629cfe70e13a02295a6c81486598b74cef9ba2000c6
+ sha256sums = 77529a4eaa6d50a572020a023af93047b942fbde5cf4447878014037481b7f5f
sha256sums = 7e8ab46940aff7cac8d535436c8e201f37c66637416ae9b795706a4c3dd01232
pkgname = python-tf2onnx
diff --git a/PKGBUILD b/PKGBUILD
index 2eab420634d1..cfb5b6b1de9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=python-tf2onnx
epoch=1
-pkgver=1.12.0
-pkgrel=2
+pkgver=1.12.1
+pkgrel=1
pkgdesc='Convert TensorFlow models to ONNX'
arch=(any)
url='https://github.com/onnx/tensorflow-onnx'
@@ -11,13 +11,13 @@ license=(MIT)
depends=(python python-tensorflow python-numpy python-onnx python-requests python-six)
makedepends=(python-setuptools python-build python-installer python-wheel)
checkdepends=(python-pytest python-graphviz python-parameterized python-yaml python-onnxruntime)
-source=("https://github.com/onnx/tensorflow-onnx/archive/v.$pkgver/tf2onnx-v$pkgver.tar.gz"
+source=("https://github.com/onnx/tensorflow-onnx/archive/v$pkgver/tf2onnx-v$pkgver.tar.gz"
"onnxruntime.diff")
-sha256sums=('958c1bd50131e91d91a79629cfe70e13a02295a6c81486598b74cef9ba2000c6'
+sha256sums=('77529a4eaa6d50a572020a023af93047b942fbde5cf4447878014037481b7f5f'
'7e8ab46940aff7cac8d535436c8e201f37c66637416ae9b795706a4c3dd01232')
prepare() {
- cd tensorflow-onnx-v.$pkgver
+ cd tensorflow-onnx-$pkgver
sed -i -r 's#--cov\S+##' setup.cfg
sed -i "s#'pytest-runner'##" setup.py
@@ -29,17 +29,20 @@ prepare() {
}
build() {
- cd tensorflow-onnx-v.$pkgver
+ cd tensorflow-onnx-$pkgver
python -m build --wheel --no-isolation
}
check() {
- cd tensorflow-onnx-v.$pkgver
- PYTHONPATH="$PWD" pytest tests
+ cd tensorflow-onnx-$pkgver
+ # Apparently the failure is caused by new operators in TensorFlow lite 2.10.0 [1][2]
+ # [1] https://github.com/tensorflow/tensorflow/commit/cac33fd25c1df270758a66fd0dadba5c973abf9a
+ # [2] https://github.com/tensorflow/tensorflow/commit/12f38bba6659b417f5408f24ebf267e05c738beb
+ PYTHONPATH="$PWD" pytest tests -k 'not test_unsorted_segment_ops'
}
package() {
- cd tensorflow-onnx-v.$pkgver
+ cd tensorflow-onnx-$pkgver
python -m installer --destdir="$pkgdir" --compile-bytecode 0 --compile-bytecode 1 --compile-bytecode 2 dist/*.whl
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}