summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192019-10-16 15:00:05 +0800
committerspecter1192019-10-16 15:00:05 +0800
commita4bf18626a2b1d0ca0435feb56ea6f4af8fa25fd (patch)
treeb10427e167b0719c370f5bb61b8ec7f441cb278b
downloadaur-a4bf18626a2b1d0ca0435feb56ea6f4af8fa25fd.tar.gz
init commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc48365e144e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-tgs
+ pkgdesc = Telegram Animated Stickers Tools
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://pypi.org/project/tgs
+ arch = any
+ license = MIT
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/t/tgs/tgs-0.3.4.tar.gz
+ source = LICENSE::https://gitlab.com/mattia.basaglia/tgs/raw/master/COPYING
+ md5sums = 012a7689a3442d3487667b024c30ac2d
+ md5sums = SKIP
+
+pkgname = python-tgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..befa940ad1cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ke Liu <spcter119@gmail.com>
+
+pkgname=python-tgs
+pkgver=0.3.4
+pkgrel=1
+pkgdesc='Telegram Animated Stickers Tools'
+arch=('any')
+url='https://pypi.org/project/tgs'
+license=('MIT')
+depends=('python')
+_pkgname=${pkgname//python-}
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "LICENSE::https://gitlab.com/mattia.basaglia/tgs/raw/master/COPYING")
+md5sums=('012a7689a3442d3487667b024c30ac2d'
+ 'SKIP')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py clean --all
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root "$pkgdir" --skip-build --optimize=1
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}