summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2016-03-23 23:06:09 -0700
committerDavid McInnis2016-03-23 23:06:09 -0700
commit8851bf8fceb42db69c2b8e23ccccf9dc6af1c47e (patch)
tree9eca442f0c1eb38249cc524279c8baf7ab897a9e
parentd34d7d88e7d6af00d55cb9d541593a80faea27d3 (diff)
downloadaur-8851bf8fceb42db69c2b8e23ccccf9dc6af1c47e.tar.gz
bumped version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 37 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5efe5b0a392f..b332311079cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 06:05:55 UTC 2016
pkgbase = python-theano
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 0.7.0
- pkgrel = 3
+ pkgver = 0.8.0
+ pkgrel = 0
url = http://www.deeplearning.net/software/theano/
arch = any
license = BSD
@@ -13,14 +15,17 @@ pkgbase = python-theano
depends = python-numpy
depends = python2
depends = python2-numpy
- optdepends = python-sympy
- optdepends = python-pycuda
+ optdepends = python-sympy: Recommended
+ optdepends = cuda>=7.0:
+ optdepends = python-pydot-ng: Preferred over python-pydot
optdepends = python-pydot
+ optdepends = python-pygpu: minimal support for opencl
optdepends = python2-sympy
- optdepends = python2-pycuda
- optdepends = python2-pydot
- source = http://pypi.python.org/packages/source/T/Theano/Theano-0.7.0.tar.gz
- sha256sums = 05b0f6d2467735abea13bdc5c2c1ce3c53f1b89f9ebc5a43abdf71f88cf818b3
+ optdepends = python2-pydot-ng
+ optdepends = python-pydot
+ optdepends = python2-pygpu
+ source = http://pypi.python.org/packages/source/T/Theano/Theano-0.8.0.tar.gz
+ sha256sums = 87f117277ebc3a3cd5394d2ae3e65a2aa3f8da3265a33e2a5c1ee63a9e6bceb5
pkgname = python-theano
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 23cdcec9fa51..4dff1ed7f0d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase="python-theano"
pkgname=("python-theano" "python2-theano")
_pkgname="Theano"
-pkgver="0.7.0"
-pkgrel="3"
+pkgver="0.8.0"
+pkgrel="0"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
url='http://www.deeplearning.net/software/theano/'
@@ -13,10 +13,17 @@ depends=('python' 'python-numpy'
'python2' 'python2-numpy')
makedepends=('python-distribute' 'python2-distribute')
checkdepends=('python-nose' 'python2-nose')
-optdepends=('python-sympy' 'python-pycuda' 'python-pydot'
- 'python2-sympy' 'python2-pycuda' 'python2-pydot')
+optdepends=('python-sympy: Recommended'
+ 'cuda>=7.0:' #Can cause tests to fail
+ 'python-pydot-ng: Preferred over python-pydot'
+ 'python-pydot'
+ 'python-pygpu: minimal support for opencl' # Can cause tests to fail
+ 'python2-sympy'
+ 'python2-pydot-ng'
+ 'python-pydot'
+ 'python2-pygpu')
source=("http://pypi.python.org/packages/source/T/Theano/Theano-${pkgver}.tar.gz")
-sha256sums=('05b0f6d2467735abea13bdc5c2c1ce3c53f1b89f9ebc5a43abdf71f88cf818b3')
+sha256sums=('87f117277ebc3a3cd5394d2ae3e65a2aa3f8da3265a33e2a5c1ee63a9e6bceb5')
prepare() {
cd "$srcdir/"
@@ -41,18 +48,24 @@ build() {
cp -f build/scripts-3.5/* bin/
}
-# Check always fails on non-64 bit platforms. Check frequently fails if optional dependencies are present
-# Even if check succeeds it takes hours to complete
-#
+# Test takes 3+ hours and over 10Gb of RAM/SWAP
+# All tests passed on my machine except the following:
+
+# ERROR: test_err_bound_list (theano.tensor.tests.test_subtensor.T_subtensor)
+# ----------------------------------------------------------------------
+# IndexError: index 4 is out of bounds for axis 0 with size 2
+
+
#check() {
# msg "Checking Python 2"
# cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
+# THEANO_FLAGS='device=cpu,optdb.max_use_ratio=40' OMP_NUM_THREADS=4 \
# ../../scripts-2.7/theano-nose -v
#
-#
# msg "Checking Python 3"
# cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
-# ../../scripts-3.4/theano-nose -v
+# THEANO_FLAGS='device=cpu,optdb.max_use_ratio=200' OMP_NUM_THREADS=4 \
+# ../../scripts-3.5/theano-nose
#}
package_python2-theano() {
@@ -70,4 +83,4 @@ package_python-theano() {
cd "$srcdir/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-theano"
-} \ No newline at end of file
+}