summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2016-03-30 18:24:07 -0700
committerDavid McInnis2016-03-30 18:24:07 -0700
commitc552bfa6c3b7e746dc70ea13f6c1bb9c7e4195b8 (patch)
treedcacddde6d6a1bc7ef58cea20d8fe3f06c7739dc
parent9b5370ccd103dd66ebbca083fa58b17d91773466 (diff)
downloadaur-c552bfa6c3b7e746dc70ea13f6c1bb9c7e4195b8.tar.gz
point release and patch for failing test on python 3.5
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-problem-with-python-3.5.patch44
-rw-r--r--PKGBUILD36
3 files changed, 70 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 189117bdc41d..7374c1e05573 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 25 22:00:55 UTC 2016
+# Thu Mar 31 01:23:27 UTC 2016
pkgbase = python-theano
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 0.8.0
+ pkgver = 0.8.1
pkgrel = 1
url = http://www.deeplearning.net/software/theano/
arch = any
@@ -24,8 +24,10 @@ pkgbase = python-theano
optdepends = python2-pydot-ng
optdepends = python-pydot
optdepends = python2-pygpu
- source = http://pypi.python.org/packages/source/T/Theano/Theano-0.8.0.tar.gz
- sha256sums = 87f117277ebc3a3cd5394d2ae3e65a2aa3f8da3265a33e2a5c1ee63a9e6bceb5
+ source = http://pypi.python.org/packages/source/T/Theano/Theano-0.8.1.tar.gz
+ source = 0001-Fix-problem-with-python-3.5.patch
+ sha256sums = 2f1d9ad7ecf136e7978a6720fa9286f7b02221c5599b935e9f7fa14cd29cb19d
+ sha256sums = b522bb513278635487a8e50f5d6b1aca003900cc92fd2450ac843daeb6c69216
pkgname = python-theano
depends = python
diff --git a/0001-Fix-problem-with-python-3.5.patch b/0001-Fix-problem-with-python-3.5.patch
new file mode 100644
index 000000000000..2a475b6c35f8
--- /dev/null
+++ b/0001-Fix-problem-with-python-3.5.patch
@@ -0,0 +1,44 @@
+From 78154521097a852dd82c614580e730ab1cd132ad Mon Sep 17 00:00:00 2001
+From: Pascal Lamblin <lamblinp@iro.umontreal.ca>
+Date: Tue, 22 Mar 2016 11:45:25 -0400
+Subject: [PATCH] Fix problem with python 3.5.
+
+It would raise a SystemError wrapping the IndexError already raised.
+---
+ theano/tensor/subtensor.py | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/theano/tensor/subtensor.py b/theano/tensor/subtensor.py
+index 4d3deca..112db06 100644
+--- a/theano/tensor/subtensor.py
++++ b/theano/tensor/subtensor.py
+@@ -1956,6 +1956,7 @@ class AdvancedIncSubtensor1(Op):
+ copy_of_x = self.copy_of_x(x)
+
+ return """
++ PyObject* rval = NULL;
+ if (%(inplace)s)
+ {
+ if (%(x)s != %(out)s)
+@@ -1971,12 +1972,16 @@ class AdvancedIncSubtensor1(Op):
+ %(out)s = %(copy_of_x)s;
+ }
+ PyObject *arglist = Py_BuildValue("OOOi",%(out)s, %(idx)s, %(y)s, %(inc_or_set)d);
+- inplace_increment(NULL, arglist);
++ rval = inplace_increment(NULL, arglist);
+ Py_XDECREF(arglist);
++ if (rval == NULL) {
++ %(fail)s;
++ }
++ Py_XDECREF(rval);
+ """ % locals()
+
+ def c_code_cache_version(self):
+- return (1,)
++ return (2,)
+
+ def perform(self, node, inp, out_):
+ # TODO opt to make this inplace
+--
+2.7.4
+
diff --git a/PKGBUILD b/PKGBUILD
index 374b61849e81..9fd66b391c9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: David McInnis<davidm@eagles.ewu.edu>
+# Maintainer: David McInnis <davidm@eagles.ewu.edu>
pkgbase="python-theano"
pkgname=("python-theano" "python2-theano")
_pkgname="Theano"
-pkgver="0.8.0"
+pkgver="0.8.1"
pkgrel="1"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
@@ -22,13 +22,16 @@ optdepends=('python-sympy: Recommended'
'python2-pydot-ng'
'python-pydot'
'python2-pygpu')
-source=("http://pypi.python.org/packages/source/T/Theano/Theano-${pkgver}.tar.gz")
-sha256sums=('87f117277ebc3a3cd5394d2ae3e65a2aa3f8da3265a33e2a5c1ee63a9e6bceb5')
+source=("http://pypi.python.org/packages/source/T/Theano/Theano-${pkgver}.tar.gz"
+ "0001-Fix-problem-with-python-3.5.patch")
+sha256sums=('2f1d9ad7ecf136e7978a6720fa9286f7b02221c5599b935e9f7fa14cd29cb19d'
+ 'b522bb513278635487a8e50f5d6b1aca003900cc92fd2450ac843daeb6c69216')
prepare() {
cd "${_pkgname}-${pkgver}"
chmod +x "${_pkgname}.egg-info"
chmod 644 ${_pkgname}.egg-info/*
+ patch -p1 < ../0001-Fix-problem-with-python-3.5.patch
cd "$srcdir/"
cp -a "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2"
cd "${_pkgname}-${pkgver}"
@@ -51,24 +54,25 @@ build() {
cp -f build/scripts-3.5/* bin/
}
-# Test takes 3+ hours and over 10Gb of RAM/SWAP
-# All tests passed on my machine except the following:
-
-# ERROR: test_err_bound_list (theano.tensor.tests.test_subtensor.T_subtensor)
-# ----------------------------------------------------------------------
-# IndexError: index 4 is out of bounds for axis 0 with size 2
-
-
+# Test takes 4+ hours and over 10Gb of RAM/SWAP
+# All tests passed on my machine
+#-------------------------------------------------
#check() {
# msg "Checking Python 2"
# cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
-# THEANO_FLAGS='device=cpu,optdb.max_use_ratio=40' OMP_NUM_THREADS=4 \
-# ../../scripts-2.7/theano-nose -v
+# THEANO_FLAGS='device=cpu,\
+# optdb.max_use_ratio=200,\
+# exception_verbosity=high' \
+# OMP_NUM_THREADS=4 \
+# nosetests2 -v -d
#
# msg "Checking Python 3"
# cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
-# THEANO_FLAGS='device=cpu,optdb.max_use_ratio=200' OMP_NUM_THREADS=4 \
-# ../../scripts-3.5/theano-nose
+# THEANO_FLAGS='device=cpu,\
+# optdb.max_use_ratio=200,\
+# exception_verbosity=high' \
+# OMP_NUM_THREADS=4 \
+# nosetests3 -v -d
#}
package_python2-theano() {