summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-11-15 19:18:59 -0500
committerJon Gjengset2015-11-15 19:20:10 -0500
commit1c0fb42f9a23011494bedd50cdd40dd6fe94e4ac (patch)
tree322ec194f37b0ca6e1f45af7bac28e9ec07b31a7
parentc81ecf4ba2ecad1de1c3df47375c176874aa1180 (diff)
downloadaur-1c0fb42f9a23011494bedd50cdd40dd6fe94e4ac.tar.gz
Add python six dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af1053771848..5e3a7427fe09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-theano-git
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 0.7.1a1.r1287.4260bbf
+ pkgver = 0.7.1a1.r1364.33c9760
pkgrel = 1
url = http://www.deeplearning.net/software/theano/
arch = any
@@ -11,8 +11,10 @@ pkgbase = python-theano-git
makedepends = python2-distribute
depends = python
depends = python-numpy
+ depends = python-six
depends = python2
depends = python2-numpy
+ depends = python2-six
optdepends = python-pycuda
optdepends = python-pydot
optdepends = python2-pycuda
@@ -27,6 +29,7 @@ pkgbase = python-theano-git
pkgname = python-theano-git
depends = python
depends = python-numpy
+ depends = python-six
optdepends = python-pycuda
optdepends = python-pydot
provides = python-theano
@@ -35,6 +38,7 @@ pkgname = python-theano-git
pkgname = python2-theano-git
depends = python2
depends = python2-numpy
+ depends = python2-six
optdepends = python2-pycuda
optdepends = python2-pydot
provides = python2-theano
diff --git a/PKGBUILD b/PKGBUILD
index f5f2dc94fa5c..1349ee481bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase="python-theano-git"
pkgname=("python-theano-git" "python2-theano-git")
-pkgver=0.7.1a1.r1287.4260bbf
+pkgver=0.7.1a1.r1364.33c9760
pkgrel=1
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
@@ -11,8 +11,8 @@ url='http://www.deeplearning.net/software/theano/'
license=('BSD')
conflicts=('python-theano' 'python2-theano')
provides=('python-theano' 'python2-theano')
-depends=('python' 'python-numpy'
- 'python2' 'python2-numpy')
+depends=('python' 'python-numpy' 'python-six'
+ 'python2' 'python2-numpy' 'python2-six')
makedepends=('python-distribute' 'python2-distribute')
checkdepends=('python-nose' 'python2-nose')
optdepends=('python-pycuda' 'python-pydot'
@@ -50,7 +50,7 @@ build() {
}
package_python2-theano-git() {
- depends=('python2' 'python2-numpy')
+ depends=('python2' 'python2-numpy' 'python2-six')
optdepends=('python2-pycuda' 'python2-pydot')
provides=('python2-theano')
conflicts=('python2-theano')
@@ -63,7 +63,7 @@ package_python2-theano-git() {
}
package_python-theano-git() {
- depends=('python' 'python-numpy')
+ depends=('python' 'python-numpy' 'python-six')
optdepends=('python-pycuda' 'python-pydot')
provides=('python-theano')
conflicts=('python-theano')