summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTK2019-04-10 10:30:42 +1000
committerTK2019-04-10 10:30:42 +1000
commit1b2172f3a8b34299f696d7725e6b9adb5ab37eb0 (patch)
tree224734c5d6ba838139e3eaa4c0e7d6dd92492f39
downloadaur-1b2172f3a8b34299f696d7725e6b9adb5ab37eb0.tar.gz
init
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
-rw-r--r--theHarvester.install9
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0a1967ff627
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = python-theharvester-git
+ pkgdesc = A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers).
+ pkgver = 3.0.6.r421.g9f7811d
+ pkgrel = 1
+ url = https://github.com/laramies/theHarvester
+ install = theHarvester.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = bash
+ depends = bash
+ depends = python-setuptools
+ depends = python
+ depends = python-yaml
+ depends = python-requests
+ depends = python-plotly
+ depends = python-pytest
+ depends = python-texttable
+ depends = python-shodan
+ depends = python-beautifulsoup4
+ depends = python-yaml
+ depends = python-decorator
+ depends = python-censys
+ provides = python-theharvester-git
+ conflicts = python-theharvester-git
+ source = python-theharvester-git::git+https://github.com/laramies/theHarvester.git
+ md5sums = SKIP
+
+pkgname = python-theharvester-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e8e0f6c2013
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+python-theharvester-git-*
+python-theharvester-git/
+src/
+stash.sqlite
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a553469bf60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Sebastian Neef <aur AT gehaxelt DOT IN>
+pkgbase=python-theharvester-git
+pkgname=python-theharvester-git
+pkgver=3.0.6.r421.g9f7811d
+pkgrel=1
+pkgdesc="A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers)."
+arch=('any')
+url="https://github.com/laramies/theHarvester"
+license=('GPL2')
+depends=(
+ 'python'
+ 'python-yaml'
+ 'python-requests'
+ 'python-plotly'
+ 'python-pytest'
+ 'python-texttable'
+ 'python-shodan'
+ 'python-beautifulsoup4'
+ 'python-yaml'
+ 'python-decorator'
+ 'python-censys'
+)
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+install="theHarvester.install"
+source=("$pkgname::git+https://github.com/laramies/theHarvester.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --user --root=${pkgdir} --optimize=1 --skip-build
+}
+
+check(){
+ cd "$srcdir"
+ pytest
+}
diff --git a/theHarvester.install b/theHarvester.install
new file mode 100644
index 000000000000..7a417b072ae8
--- /dev/null
+++ b/theHarvester.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "IMPORTANT: The location of API keys has changed!"
+ echo "Add your keys to /opt/theharvester-git/api-keys.yaml"
+ echo " bingapi"
+ echo " hunter"
+ echo " intelx"
+ echo " securitytrails"
+ echo " shodan"
+}