summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors-ol2017-04-10 21:54:27 +0200
committers-ol2017-04-10 22:00:34 +0200
commit5851d9ab3a6bc8c5f4509f114b5b05de8a50847b (patch)
tree6f61556fc633cc3a95b11fc9bb86c2fb8c92f1b3
parent12f4140290ca03d1387878aa6caf2043e17003ef (diff)
downloadaur-5851d9ab3a6bc8c5f4509f114b5b05de8a50847b.tar.gz
add .gitignore
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7393224f66d0..89d9d6c5bc83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-themer-git
pkgdesc = Themer is a colorscheme generator and manager for your desktop.
pkgver = 0.0.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/s-ol/themer
install = themer.install
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c33ef50add36
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 40d653b34518..2728f0c7a87a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _gitbranch=master
pkgname="python-${_gitname}-git"
pkgdesc='Themer is a colorscheme generator and manager for your desktop.'
pkgver=0.0.0
-pkgrel=5
+pkgrel=6
url="https://github.com/s-ol/${_gitname}"
license=('MIT')
arch=('any')
@@ -28,12 +28,14 @@ package() {
cd "${_gitname}"
python setup.py install --root="${pkgdir}" --optimize=1
- # Default Configuration
- install -Dm644 "data/default" "${pkgdir}/usr/share/${_gitname}/default"
+ # License
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+
+ cd data/
# Fish Completion
- install -Dm644 "data/fish/themer.fish" "${pkgdir}/usr/share/fish/completions/${_gitname}.fish"
+ install -Dm644 "fish/themer.fish" "${pkgdir}/usr/share/fish/completions/${_gitname}.fish"
- # License
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+ # Default Configuration
+ find default -type f -exec install -Dm 644 '{}' "${pkgdir}/usr/share/${_gitname}/{}" ';'
}