summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-21 12:24:46 -0500
committerDanManN2018-12-21 12:24:46 -0500
commit93f5b0d6fe7256693205a0556a00ffb9140ab40b (patch)
treea33df9b78a64a471f91f84ffce110cc2723eb2c2
parent90f6d8dcc3cc2ac6724c631235c6e0300615316f (diff)
downloadaur-93f5b0d6fe7256693205a0556a00ffb9140ab40b.tar.gz
make depends + version fix
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8ca77280753..5cf99c71086d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-thinc-git
pkgdesc = Practical Machine Learning for NLP
- pkgver = 7.0.0.dev6.r2716.f26cb395
- pkgrel = 1
+ pkgver = 6.12.1.r2400.a6badde8
+ pkgrel = 2
url = https://github.com/explosion/thinc
arch = x86_64
license = MIT
+ makedepends = git
makedepends = python-setuptools
depends = cython
depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 0f67d79be4f2..a7d1e1c6432c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Python package author: Matthew Honnibal <matt@explosion.ai>
pkgname=python-thinc-git
_origpkgname=thinc
-pkgver=7.0.0.dev6.r2716.f26cb395
-pkgrel=1
+pkgver=6.12.1.r2400.a6badde8
+pkgrel=2
pkgdesc="Practical Machine Learning for NLP"
arch=("x86_64")
url="https://github.com/explosion/thinc"
@@ -26,16 +26,21 @@ depends=('cython'
'python-blis'
'flake8'
)
-makedepends=("python-setuptools")
-optdepends=("python-spacy: examples")
+makedepends=('git' 'python-setuptools')
+optdepends=('python-spacy: examples')
provides=('python-thinc')
conflicts=('python-thinc')
source=("git+https://github.com/explosion/$_origpkgname.git")
md5sums=('SKIP')
+prepare() {
+ cd "$_origpkgname"
+ git checkout $(curl https://api.github.com/repos/explosion/$_origpkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
+}
+
pkgver() {
cd "$_origpkgname"
- printf "%s.r%s.%s" "$(cat thinc/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "$(cat thinc/about.py | grep -i version | grep -v '#' | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {