summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-05 22:14:21 -0500
committerDanManN2018-12-05 22:14:21 -0500
commitad90442d24cb30ce845d5bb42cb7f435d325ecbd (patch)
treeed57720392fec0928749dedc9628afefc015447f
downloadaur-ad90442d24cb30ce845d5bb42cb7f435d325ecbd.tar.gz
a spacy thing
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD45
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98be6d38f516
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = python-thinc
+ pkgdesc = Practical Machine Learning for NLP
+ pkgver = 7.0.0.dev6.r2716.f26cb395
+ pkgrel = 1
+ url = https://github.com/explosion/thinc
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = cython
+ depends = python-numpy
+ depends = python-murmurhash
+ depends = python-cymem
+ depends = python-preshed
+ depends = python-wrapt
+ depends = python-plac
+ depends = python-tqdm
+ depends = python-srsly
+ depends = python-wasabi
+ depends = python-six
+ depends = python
+ depends = python-hypothesis
+ depends = python-pytest
+ depends = python-mock
+ depends = python-blis
+ depends = flake8
+ optdepends = python-spacy: examples
+ provides = python-thinc
+ conflicts = python-thinc
+ source = git+https://github.com/explosion/thinc.git
+ md5sums = SKIP
+
+pkgname = python-thinc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b90fbb65429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: DanManN <dnahimov@gmail.com>
+# Python package author: Matthew Honnibal <matt@explosion.ai>
+pkgname=python-thinc
+_origpkgname=thinc
+pkgver=7.0.0.dev6.r2716.f26cb395
+pkgrel=1
+pkgdesc="Practical Machine Learning for NLP"
+arch=("x86_64")
+url="https://github.com/explosion/thinc"
+license=("MIT")
+depends=('cython'
+ 'python-numpy'
+ 'python-murmurhash'
+ 'python-cymem'
+ 'python-preshed'
+ 'python-wrapt'
+ 'python-plac'
+ 'python-tqdm'
+ 'python-srsly'
+ 'python-wasabi'
+ 'python-six'
+ 'python'
+ 'python-hypothesis'
+ 'python-pytest'
+ 'python-mock'
+ 'python-blis'
+ 'flake8'
+)
+makedepends=("python-setuptools")
+optdepends=("python-spacy: examples")
+provides=('python-thinc')
+conflicts=('python-thinc')
+source=("git+https://github.com/explosion/$_origpkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_origpkgname"
+ printf "%s.r%s.%s" "$(cat thinc/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_origpkgname"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}