summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-10-16 15:06:08 +0200
committerPhilip Goto2020-10-16 15:06:08 +0200
commitdc89a8e8ced1b96972787c763650adceca149e77 (patch)
treed0d687883e1aed21fe3aab160986ffa744327d33
parent45643a342636f5d48f69bf6ddbfe1e7f35e30af7 (diff)
downloadaur-dc89a8e8ced1b96972787c763650adceca149e77.tar.gz
Update
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD78
2 files changed, 56 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3f72ec64481..dc8c670bd455 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,31 @@
pkgbase = python-thinc-git
pkgdesc = Practical Machine Learning for NLP
- pkgver = 6.12.1.r2400.a6badde8
- pkgrel = 3
+ pkgver = 8.0.0rc0.r0.g36e20cee
+ pkgrel = 1
url = https://github.com/explosion/thinc
+ arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = MIT
makedepends = git
makedepends = python-setuptools
- depends = cython
- depends = python-numpy
- depends = python-murmurhash
+ makedepends = cython
+ depends = python-blis
+ depends = python-catalogue
depends = python-cymem
- depends = python-preshed
- depends = python-wrapt
- depends = python-plac
- depends = python-tqdm
- depends = python-six
- depends = python-dill
depends = python-hypothesis
- depends = python-pytest
depends = python-mock
- depends = python-blis
- depends = python-msgpack-numpy
- depends = python-msgpack
- depends = python-cytoolz
- optdepends = python-spacy: examples
+ depends = python-murmurhash
+ depends = python-numpy
+ depends = python-pathlib
+ depends = python-plac
+ depends = python-preshed
+ depends = python-pydantic
+ depends = python-six
+ depends = python-srsly
+ depends = python-tqdm
+ depends = python-wasabi
provides = python-thinc
conflicts = python-thinc
source = git+https://github.com/explosion/thinc.git
diff --git a/PKGBUILD b/PKGBUILD
index 2118382c6933..ba72eb9214e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,49 @@
-# Maintainer: DanManN <dnahimov@gmail.com>
-# Python package author: Matthew Honnibal <matt@explosion.ai>
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: DanManN <dnahimov@gmail.com>
+
pkgname=python-thinc-git
-_origpkgname=thinc
-pkgver=6.12.1.r2400.a6badde8
-pkgrel=3
+pkgver=8.0.0rc0.r0.g36e20cee
+pkgrel=1
pkgdesc="Practical Machine Learning for NLP"
-arch=("x86_64")
+arch=(i686 x86_64 armv7h aarch64)
url="https://github.com/explosion/thinc"
-license=("MIT")
-depends=('cython'
- 'python-numpy'
- 'python-murmurhash'
- 'python-cymem'
- 'python-preshed'
- 'python-wrapt'
- 'python-plac'
- 'python-tqdm'
- 'python-six'
- 'python-dill'
- 'python-hypothesis'
- 'python-pytest'
- 'python-mock'
- 'python-blis'
- 'python-msgpack-numpy'
- 'python-msgpack'
- 'python-cytoolz'
- )
-
-makedepends=('git' 'python-setuptools')
-optdepends=('python-spacy: examples')
-provides=('python-thinc')
-conflicts=('python-thinc')
-source=("git+https://github.com/explosion/$_origpkgname.git")
+license=(MIT)
+depends=(
+ python-blis
+ python-catalogue
+ python-cymem
+ python-hypothesis
+ python-mock
+ python-murmurhash
+ python-numpy
+ python-pathlib
+ python-plac
+ python-preshed
+ python-pydantic
+ python-six
+ python-srsly
+ python-tqdm
+ python-wasabi
+)
+makedepends=(git python-setuptools cython)
+provides=(python-thinc)
+conflicts=(python-thinc)
+source=("git+https://github.com/explosion/thinc.git")
md5sums=('SKIP')
-prepare() {
- cd "$_origpkgname"
- git checkout $(curl https://api.github.com/repos/explosion/$_origpkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
-}
pkgver() {
- cd "$_origpkgname"
- printf "%s.r%s.%s" "$(cat thinc/about.py | grep -i version | grep -v '#' | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd thinc
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd thinc
+ python setup.py build
}
package() {
- cd "$_origpkgname"
- python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd thinc
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}