summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-06-22 13:30:44 +0200
committerPhilip Goto2021-06-22 13:30:44 +0200
commitfe025a76885517626f04ef5e5b447be813ed64ff (patch)
treef1d696a7975bcaed0833d5edacb99a1870d476f7
parentdc89a8e8ced1b96972787c763650adceca149e77 (diff)
downloadaur-fe025a76885517626f04ef5e5b447be813ed64ff.tar.gz
Update version
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD61
2 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc8c670bd455..474b78c2b0f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,9 @@
pkgbase = python-thinc-git
pkgdesc = Practical Machine Learning for NLP
- pkgver = 8.0.0rc0.r0.g36e20cee
+ pkgver = 8.0.6.r0.g2cdd3d28
pkgrel = 1
url = https://github.com/explosion/thinc
- arch = i686
arch = x86_64
- arch = armv7h
arch = aarch64
license = MIT
makedepends = git
@@ -29,7 +27,6 @@ pkgbase = python-thinc-git
provides = python-thinc
conflicts = python-thinc
source = git+https://github.com/explosion/thinc.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = python-thinc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ba72eb9214e1..2df98c2f0146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,51 @@
# Contributor: DanManN <dnahimov@gmail.com>
pkgname=python-thinc-git
-pkgver=8.0.0rc0.r0.g36e20cee
+pkgver=8.0.6.r0.g2cdd3d28
pkgrel=1
-pkgdesc="Practical Machine Learning for NLP"
-arch=(i686 x86_64 armv7h aarch64)
-url="https://github.com/explosion/thinc"
+pkgdesc='Practical Machine Learning for NLP'
+arch=(x86_64 aarch64)
+url='https://github.com/explosion/thinc'
license=(MIT)
depends=(
- python-blis
- python-catalogue
- python-cymem
- python-hypothesis
- python-mock
- python-murmurhash
- python-numpy
- python-pathlib
- python-plac
- python-preshed
- python-pydantic
- python-six
- python-srsly
- python-tqdm
- python-wasabi
+ python-blis
+ python-catalogue
+ python-cymem
+ python-hypothesis
+ python-mock
+ python-murmurhash
+ python-numpy
+ python-pathlib
+ python-plac
+ python-preshed
+ python-pydantic
+ python-six
+ python-srsly
+ python-tqdm
+ python-wasabi
+)
+makedepends=(
+ git
+ python-setuptools
+ cython
)
-makedepends=(git python-setuptools cython)
provides=(python-thinc)
conflicts=(python-thinc)
source=("git+https://github.com/explosion/thinc.git")
-md5sums=('SKIP')
-
+sha256sums=('SKIP')
pkgver() {
- cd thinc
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd thinc
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd thinc
- python setup.py build
+ cd thinc
+ python setup.py build
}
package() {
- cd thinc
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ cd thinc
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}