summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealfanyujun2023-10-11 20:38:33 +0800
committerrealfanyujun2023-10-11 20:38:33 +0800
commitc87c8927955387e5aaf2b5de471ec9ddd7b74a49 (patch)
tree3d78b8cacfe0c2da3a7de575cd3b57d604000a7c
downloadaur-c87c8927955387e5aaf2b5de471ec9ddd7b74a49.tar.gz
new submit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce5585a3d361
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-thop
+ pkgdesc = Count the MACs / FLOPs of your PyTorch model.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Lyken17/pytorch-OpCounter
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pytorch
+ source = pytorch-OpCounter-master.zip::https://github.com/Lyken17/pytorch-OpCounter/archive/refs/heads/master.zip
+ sha256sums = 9dd5999570452100f8082c360ab3d9cbf9bcad22b7fb87ed8bcfff20dbc02433
+
+pkgname = python-thop
+ depends = python
+ depends = python-pytorch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6af5e5f6c4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: fanyujun <dlutfyj@outlook.com>
+# Contributor:
+
+pkgname="python-thop"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Count the MACs / FLOPs of your PyTorch model.'
+arch=(any)
+url="https://github.com/Lyken17/pytorch-OpCounter"
+license=(MIT)
+depends=(python python-pytorch)
+conflicts=()
+makedepends=(python-setuptools)
+source=(pytorch-OpCounter-master.zip::"$url/archive/refs/heads/master.zip")
+sha256sums=('9dd5999570452100f8082c360ab3d9cbf9bcad22b7fb87ed8bcfff20dbc02433')
+
+build() {
+ cd "${srcdir}/pytorch-OpCounter-master"
+ python setup.py build
+}
+
+package(){
+ depends+=()
+ cd "${srcdir}/pytorch-OpCounter-master"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}