summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-30 20:30:13 -0500
committerGuillaume Horel2017-01-30 20:30:13 -0500
commit57e4c0fec1503446601c221e62d4ab20c6fb44ab (patch)
treeb109b34f3118454875cfe460ce123807271b1ed1
downloadaur-57e4c0fec1503446601c221e62d4ab20c6fb44ab.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d642fac0e108
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-thriftpy
+ pkgdesc = Pure python implementation of Apache Thrift.
+ pkgver = 0.3.9
+ pkgrel = 1
+ url = https://thriftpy.readthedocs.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-tornado
+ source = https://github.com/eleme/thriftpy/archive/v0.3.9.tar.gz
+ sha256sums = 34b1c12a264d030013bca3aeed87987c90dc260d14066a1cdf294b887aa49ad1
+
+pkgname = python-thriftpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c26ae1d030f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-thriftpy')
+_module='thriftpy'
+pkgver='0.3.9'
+pkgrel=1
+pkgdesc="Pure python implementation of Apache Thrift."
+url="https://thriftpy.readthedocs.org/"
+depends=('python')
+makedepends=(
+ 'cython'
+ 'python-setuptools')
+optdepends=('python-tornado')
+license=('MIT')
+arch=('i686' 'x86_64')
+source=("https://github.com/eleme/thriftpy/archive/v$pkgver.tar.gz")
+sha256sums=('34b1c12a264d030013bca3aeed87987c90dc260d14066a1cdf294b887aa49ad1')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}