summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-03-27 21:14:35 -0400
committerGuillaume Horel2021-03-27 21:14:35 -0400
commitcdb45a878569638576ebbde30067582597b90e6e (patch)
tree62faca3cf5bca365754c9d55d60fd9fa79bfca7e
downloadaur-cdb45a878569638576ebbde30067582597b90e6e.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a66776d73a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-thriftpy2
+ pkgdesc = A pure python implementation of Apache Thrift in a pythonic way
+ pkgver = 0.4.14
+ pkgrel = 1
+ url = https://thriftpy2.readthedocs.io
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-pytest-asyncio
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python-ply
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/t/thriftpy2/thriftpy2-0.4.14.tar.gz
+ sha256sums = 1758ccaeb2a40d8779b50cdd3d7a3b43e8c5752f21ad0a54ded7c251d05219e8
+
+pkgname = python-thriftpy2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2490925cf70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-thriftpy2'
+_pkgname=thriftpy2
+pkgver=0.4.14
+pkgrel=1
+pkgdesc='A pure python implementation of Apache Thrift in a pythonic way'
+arch=('any')
+url='https://thriftpy2.readthedocs.io'
+license=('MIT')
+makedepends=('cython' 'python-setuptools')
+depends=('python-ply')
+checkdepends=('python-pytest' 'python-pytest-asyncio')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('1758ccaeb2a40d8779b50cdd3d7a3b43e8c5752f21ad0a54ded7c251d05219e8')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build_ext --inplace
+ cd "tests"
+ PYTHONPATH=.. pytest
+}