summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-24 17:23:56 -0600
committerLuis Martinez2022-02-24 17:23:56 -0600
commit69c8a20c9ec0c080a9436d6f9f64b4f9af6d31ad (patch)
treed726aee6c30ef17af278fcf82c741dfd0b6a7b00
parent6fc4f43044364fe9ccf5c3ab47d763ae7255124c (diff)
downloadaur-69c8a20c9ec0c080a9436d6f9f64b4f9af6d31ad.tar.gz
use python-installer for packaging
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b79806c058b..32fa5d854aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-tidalapi
pkgdesc = Unofficial API for TIDAL music streaming service.
pkgver = 0.6.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tamland/python-tidal
changelog = HISTORY.rst
arch = any
license = LGPL3
makedepends = git
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-wheel
makedepends = python-sphinx
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index f9da599fcd75..8bc6d1456913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-tidalapi
pkgver=0.6.10
-pkgrel=1
+pkgrel=2
pkgdesc='Unofficial API for TIDAL music streaming service.'
arch=('any')
url='https://github.com/tamland/python-tidal'
@@ -12,7 +12,7 @@ depends=('python-requests')
makedepends=(
'git'
'python-build'
- 'python-install'
+ 'python-installer'
'python-wheel'
'python-sphinx'
'python-setuptools')
@@ -23,7 +23,7 @@ validpgpkeys=('E09E6FC5E0472F735B7599C4BBEDD0C513635C9F')
build() {
cd "$pkgname"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
cd docs
sphinx-build -b man . _build/man
}
@@ -33,6 +33,6 @@ build() {
package() {
export PYTHONHASHSEED=0
cd "$pkgname"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 docs/_build/man/tidalapi.1 -t "$pkgdir/usr/share/man/man1/"
}