summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-09 22:58:09 -0600
committerLuis Martinez2022-02-09 22:59:22 -0600
commit6fc4f43044364fe9ccf5c3ab47d763ae7255124c (patch)
treeb0452ff2117d739a1e0abf3e8462b819942d9ea9
parent4e39eda215926233aef22b10855b8f5d2a27c777 (diff)
downloadaur-6fc4f43044364fe9ccf5c3ab47d763ae7255124c.tar.gz
update to 0.6.10
-rw-r--r--.SRCINFO11
-rw-r--r--HISTORY.rst65
-rw-r--r--PKGBUILD18
3 files changed, 87 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2048c3214721..9b79806c058b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = python-tidalapi
pkgdesc = Unofficial API for TIDAL music streaming service.
- pkgver = 0.6.9
+ pkgver = 0.6.10
pkgrel = 1
url = https://github.com/tamland/python-tidal
+ changelog = HISTORY.rst
arch = any
license = LGPL3
- makedepends = python-setuptools
makedepends = git
+ makedepends = python-build
+ makedepends = python-install
+ makedepends = python-wheel
+ makedepends = python-sphinx
+ makedepends = python-setuptools
depends = python-requests
- source = python-tidalapi::git+https://github.com/tamland/python-tidal#tag=v0.6.9?signed
+ source = python-tidalapi::git+https://github.com/tamland/python-tidal#tag=v0.6.10?signed
validpgpkeys = E09E6FC5E0472F735B7599C4BBEDD0C513635C9F
sha256sums = SKIP
diff --git a/HISTORY.rst b/HISTORY.rst
new file mode 100644
index 000000000000..c0eb17791a77
--- /dev/null
+++ b/HISTORY.rst
@@ -0,0 +1,65 @@
+.. :changelog:
+
+History
+-------
+
+v0.6.10
+-------
+ * Update the client secret - 1nikolas_
+ * Use a track url endpoint compatible with the new secret - morguldir_
+
+v0.6.9
+------
+
+* Update the client secret - morguldir_
+* Fix token_refresh() not correctly including the client secret - morguldir_
+
+v0.6.8
+------
+
+* Support OAuth login through login_oauth_simple() and login_oauth() - morguldir_
+* Support loading an OAuth session through load_oauth_session() - morguldir_
+* Include more info when a request fails - morguldir_
+
+v0.6.7
+------
+
+* Fix wimp images not resolving - ktnrg45_
+* Made the favorite playlists function also return created playlists - morguldir_
+
+v0.6.6
+------
+
+* Update api token and slightly obfuscate it - morguldir_
+
+v0.6.5
+------
+
+* Update api token - morguldir_
+
+v0.6.4
+------
+
+* Add parameter to search() allowing for more results (up to 300) - morguldir_
+* Fix get_track_url() not returning anything - morguldir_
+
+v0.6.3
+------
+
+* Fix quality options using enum names instead of values - morguldir_
+* Handle situations where tidal doesn't set the version tag - morguldir_
+
+v0.6.2
+------
+
+* Update lossless token - morguldir_
+* Always use the same api token - morguldir_
+* Include additional info when logging fails - morguldir_
+* Make user_id and country_code optional when using load_session() - morguldir_
+* Add version tag for Track - Husky22_
+* Switch to netlify for documentation - morguldir_
+
+.. _morguldir: https://github.com/morguldir
+.. _Husky22: https://github.com/Husky22
+.. _ktnrg45: https://github.com/ktnrg45
+.. _1nikolas: https://github.com/1nikolas
diff --git a/PKGBUILD b/PKGBUILD
index 24fa33a7b7dd..f9da599fcd75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,30 @@
# Contributor: John Hamelink <me@johnhame.link>
pkgname=python-tidalapi
-pkgver=0.6.9
+pkgver=0.6.10
pkgrel=1
pkgdesc='Unofficial API for TIDAL music streaming service.'
arch=('any')
url='https://github.com/tamland/python-tidal'
license=('LGPL3')
depends=('python-requests')
-makedepends=('python-setuptools' 'git')
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-install'
+ 'python-wheel'
+ 'python-sphinx'
+ 'python-setuptools')
+changelog=HISTORY.rst
source=("$pkgname::git+$url#tag=v$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('E09E6FC5E0472F735B7599C4BBEDD0C513635C9F')
build() {
cd "$pkgname"
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
+ cd docs
+ sphinx-build -b man . _build/man
}
## tests require an active Tidal session
@@ -24,5 +33,6 @@ build() {
package() {
export PYTHONHASHSEED=0
cd "$pkgname"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 docs/_build/man/tidalapi.1 -t "$pkgdir/usr/share/man/man1/"
}