summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2024-04-18 14:30:24 +0800
committerYour Name2024-04-18 14:30:24 +0800
commit24042b25121a424a58a79b44ff518204f7e83a47 (patch)
tree7ea8dba855a2dba64ad50c900f9fc3317f44cf50
parent2fb26b07c576bd385878ac24655e3cd08065d33a (diff)
downloadaur-python-tifffile.tar.gz
Update to version 2024.4.18
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7354e83a620d..2af0bdc11f97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2024.2.12
+ pkgver = 2024.4.18
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -10,15 +10,15 @@ pkgbase = python-tifffile
makedepends = python-setuptools
makedepends = python-sphinx
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2024.2.12.tar.gz
- sha256sums = 4920a3ec8e8e003e673d3c6531863c99eedd570d1b8b7e141c072ed78ff8030d
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2024.4.18.tar.gz
+ sha256sums = 5ffcd77b9d77c3aada1278631af5c8ac788438452fda2eb1b9b60d5553e95c82
pkgname = python-tifffile
- depends = python-numpy>=1.26.3
- optdepends = python-matplotlib>=3.8.2: required for plotting
+ depends = python-numpy>=1.26.4
+ optdepends = python-matplotlib>=3.8.3: required for plotting
optdepends = python-imagecodecs>=2024.1.1: required for encoding or decoding LZW, JPEG, etc. compressed segments
- optdepends = python-lxml>=4.9.2: required only for validating and printing XML
- optdepends = python-zarr>=2.16.1: required for opening Zarr stores
+ optdepends = python-lxml>=5.1.0: required only for validating and printing XML
+ optdepends = python-zarr>=2.17.0: required for opening Zarr stores
optdepends = python-fsspec>=2023.9.2: required only for opening ReferenceFileSystem files
optdepends = python-tifffile-doc: Documentation for Python tifffile
diff --git a/PKGBUILD b/PKGBUILD
index c5676d0d2ab2..1d3151478c9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=python-tifffile
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2024.2.12
+pkgver=2024.4.18
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
arch=('any')
@@ -18,7 +18,7 @@ checkdepends=('python-pytest'
'python-imagecodecs') # numpy ? xarray
# 'python-fsspec'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('4920a3ec8e8e003e673d3c6531863c99eedd570d1b8b7e141c072ed78ff8030d')
+sha256sums=('5ffcd77b9d77c3aada1278631af5c8ac788438452fda2eb1b9b60d5553e95c82')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -48,19 +48,19 @@ check() {
--deselect=tests/test_tifffile.py::test_write_5GB_fails \
--deselect=tests/test_tifffile.py::test_write_6gb \
--deselect=tests/test_tifffile.py::test_write_bigtiff \
- --deselect=tests/test_tifffile.py::test_write_imagej_raw \
- --deselect=tests/test_tifffile.py::test_issue_imagej_hyperstack_arg \
- --deselect=tests/test_tifffile.py::test_issue_description_overwrite \
- --deselect=tests/test_tifffile.py::test_issue_invalid_predictor \
- --deselect=tests/test_tifffile.py::test_issue_trucated_tileoffsets || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
+ --deselect=tests/test_tifffile.py::test_write_imagej_raw || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
+# --deselect=tests/test_tifffile.py::test_issue_imagej_hyperstack_arg \
+# --deselect=tests/test_tifffile.py::test_issue_description_overwrite \
+# --deselect=tests/test_tifffile.py::test_issue_invalid_predictor \
+# --deselect=tests/test_tifffile.py::test_issue_trucated_tileoffsets #|| warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-tifffile() {
- depends=('python-numpy>=1.26.3')
- optdepends=('python-matplotlib>=3.8.2: required for plotting'
+ depends=('python-numpy>=1.26.4')
+ optdepends=('python-matplotlib>=3.8.3: required for plotting'
'python-imagecodecs>=2024.1.1: required for encoding or decoding LZW, JPEG, etc. compressed segments'
- 'python-lxml>=4.9.2: required only for validating and printing XML'
- 'python-zarr>=2.16.1: required for opening Zarr stores'
+ 'python-lxml>=5.1.0: required only for validating and printing XML'
+ 'python-zarr>=2.17.0: required for opening Zarr stores'
'python-fsspec>=2023.9.2: required only for opening ReferenceFileSystem files'
'python-tifffile-doc: Documentation for Python tifffile')
cd ${srcdir}/${_pyname}-${pkgver}