summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-09-29 10:59:24 +0800
committerUniversebenzene2020-09-29 10:59:24 +0800
commit0b3393d484195e2b2ed4f41dc33cfe901326b4cb (patch)
treed0d7dbfdd0df2908dc183b79b3fcc297ea658832
parent9b05e260fa3b7e85f020d1c2e06d24b7d7b0aa0c (diff)
downloadaur-0b3393d484195e2b2ed4f41dc33cfe901326b4cb.tar.gz
Update to version 2020.9.28
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7b7f12ff138..1bd11b39b30a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2020.9.22
+ pkgver = 2020.9.28
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -10,8 +10,9 @@ pkgbase = python-tifffile
optdepends = python-matplotlib>=3.2.2: required only for plotting
optdepends = python-imagecodecs>=2020.5.30: required only for encoding or decoding LZW, JPEG, etc
optdepends = python-lxml>=4.5.2: required only for validating and printing XML
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2020.9.22.tar.gz
- sha256sums = 505a0ddf372697e8dacd3a8bc486f7143df44772b0fd72ca56486b6b46cbe494
+ optdepends = python-zarr>=2.4.0: required only for opening zarr storage
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2020.9.28.tar.gz
+ sha256sums = 393903af4a526b836f630aa7363071f66b3d3c1d8c865ee6693f9603262da8e9
pkgname = python-tifffile
diff --git a/PKGBUILD b/PKGBUILD
index cce430c152da..5ee76a35281e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2020.9.22
+pkgver=2020.9.28
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -13,10 +13,11 @@ makedepends=('python-setuptools')
depends=('python-numpy>=1.18.5')
optdepends=('python-matplotlib>=3.2.2: required only for plotting'
'python-imagecodecs>=2020.5.30: required only for encoding or decoding LZW, JPEG, etc'
- 'python-lxml>=4.5.2: required only for validating and printing XML')
+ 'python-lxml>=4.5.2: required only for validating and printing XML'
+ 'python-zarr>=2.4.0: required only for opening zarr storage')
#checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('505a0ddf372697e8dacd3a8bc486f7143df44772b0fd72ca56486b6b46cbe494')
+sha256sums=('393903af4a526b836f630aa7363071f66b3d3c1d8c865ee6693f9603262da8e9')
build() {
cd ${srcdir}/${_pyname}-${pkgver}