summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-08-01 15:27:45 +0800
committerUniversebenzene2022-08-01 15:27:45 +0800
commit24de0e9c1d051aac320219c26163ad0ed9388657 (patch)
tree36e9fdff6dfea2e051c318b699f8e0abd106c2b8
parentf1f47fef0dff5626595b60acd019c69524721ccf (diff)
downloadaur-24de0e9c1d051aac320219c26163ad0ed9388657.tar.gz
Update to version 2022.7.31
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6b8c77bde68..ffcb4905f16c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2022.7.28
+ pkgver = 2022.7.31
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -10,15 +10,16 @@ pkgbase = python-tifffile
checkdepends = python-fsspec
makedepends = python-setuptools
makedepends = python-sphinx
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.7.28.tar.gz
- sha256sums = 61e3638e35156751dbc3cdbd0e4cf1166b90597d5d1972d03945a96570f1ad81
+ makedepends = python-numpy
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.7.31.tar.gz
+ sha256sums = 47940a048f31fb440434ad3782ee105205b097ac44dbd0b06a498e2b52b92f88
pkgname = python-tifffile
depends = python-numpy>=1.21.5
- optdepends = python-matplotlib>=3.5.2: required only for plotting
- optdepends = python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc
+ optdepends = python-matplotlib>=3.5.2: required for plotting
+ optdepends = python-imagecodecs>=2022.7.27: required for encoding or decoding LZW, JPEG, etc. compressed segments
optdepends = python-lxml>=4.9.1: required only for validating and printing XML
- optdepends = python-zarr>=2.11.3: required only for opening zarr storage
+ optdepends = python-zarr>=2.12.0: required for opening Zarr stores
optdepends = python-tifffile-doc: Documentation for Python tifffile
pkgname = python-tifffile-doc
diff --git a/PKGBUILD b/PKGBUILD
index 9a3d9d9c1d75..47232924d727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,19 @@
pkgbase=python-tifffile
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2022.7.28
+pkgver=2022.7.31
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
makedepends=('python-setuptools'
- 'python-sphinx')
+ 'python-sphinx'
+ 'python-numpy')
#makedepends=('python-setuptools' 'python-wheel' 'python-build' 'python-installer')
checkdepends=('python-pytest' 'python-xarray' 'python-fsspec')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('61e3638e35156751dbc3cdbd0e4cf1166b90597d5d1972d03945a96570f1ad81')
+sha256sums=('47940a048f31fb440434ad3782ee105205b097ac44dbd0b06a498e2b52b92f88')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -48,10 +49,10 @@ check() {
package_python-tifffile() {
depends=('python-numpy>=1.21.5')
- optdepends=('python-matplotlib>=3.5.2: required only for plotting'
- 'python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc'
+ optdepends=('python-matplotlib>=3.5.2: required for plotting'
+ 'python-imagecodecs>=2022.7.27: required for encoding or decoding LZW, JPEG, etc. compressed segments'
'python-lxml>=4.9.1: required only for validating and printing XML'
- 'python-zarr>=2.11.3: required only for opening zarr storage'
+ 'python-zarr>=2.12.0: required for opening Zarr stores'
'python-tifffile-doc: Documentation for Python tifffile')
cd ${srcdir}/${_pyname}-${pkgver}