summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-06-07 13:12:29 +0800
committerUniversebenzene2021-06-07 13:12:29 +0800
commit3fbef2949254f67780097df6b2f3531a9845bd99 (patch)
tree5ca64ec5cdea553cda784de398a4a52252e59807
parent5ae31b250594533de93e3a354f1f428a46161607 (diff)
downloadaur-3fbef2949254f67780097df6b2f3531a9845bd99.tar.gz
Update to version 2021.6.6
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4af02d86728e..ec9e43f60f5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2021.4.8
+ pkgver = 2021.6.6
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
license = BSD
makedepends = python-setuptools
- depends = python-numpy>=1.19.5
- optdepends = python-matplotlib>=3.3.3: required only for plotting
- optdepends = python-imagecodecs>=2021.3.31: required only for encoding or decoding LZW, JPEG, etc
+ depends = python-numpy>=1.20.3
+ optdepends = python-matplotlib>=3.4.1: required only for plotting
+ optdepends = python-imagecodecs>=2021.5.20: required only for encoding or decoding LZW, JPEG, etc
optdepends = python-lxml>=4.6.3: required only for validating and printing XML
optdepends = python-zarr>=2.6.1: required only for opening zarr storage
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2021.4.8.tar.gz
- sha256sums = 55aa8baad38e1567c9fe450fff52160e4a21294a612f241c5e414da80f87209b
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2021.6.6.tar.gz
+ sha256sums = aa6c2afb75378432856e2ecfba8cba347b6615b541bb71f1f83a9860ebe8fa70
pkgname = python-tifffile
-
diff --git a/PKGBUILD b/PKGBUILD
index 543e10036819..a5c3f0be4c0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2021.4.8
+pkgver=2021.6.6
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -10,14 +10,14 @@ arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
makedepends=('python-setuptools')
-depends=('python-numpy>=1.19.5')
-optdepends=('python-matplotlib>=3.3.3: required only for plotting'
- 'python-imagecodecs>=2021.3.31: required only for encoding or decoding LZW, JPEG, etc'
+depends=('python-numpy>=1.20.3')
+optdepends=('python-matplotlib>=3.4.1: required only for plotting'
+ 'python-imagecodecs>=2021.5.20: required only for encoding or decoding LZW, JPEG, etc'
'python-lxml>=4.6.3: required only for validating and printing XML'
'python-zarr>=2.6.1: required only for opening zarr storage')
#checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('55aa8baad38e1567c9fe450fff52160e4a21294a612f241c5e414da80f87209b')
+sha256sums=('aa6c2afb75378432856e2ecfba8cba347b6615b541bb71f1f83a9860ebe8fa70')
build() {
cd ${srcdir}/${_pyname}-${pkgver}