summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-02-27 16:20:26 +0800
committerUniversebenzene2022-02-27 16:20:26 +0800
commit4d8171eb8740067dba9aa95d942bf7985efb04a4 (patch)
tree6cf9af12c74c0fe6c141b4752a83e221b092598d
parent74bee03c1bc2a074a1ccf5f643b677a503623a3c (diff)
downloadaur-4d8171eb8740067dba9aa95d942bf7985efb04a4.tar.gz
Update to version 2022.2.9
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34ce213285d9..7665d165f727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2022.2.2
+ pkgver = 2022.2.9
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -13,7 +13,7 @@ pkgbase = python-tifffile
optdepends = python-imagecodecs>=2021.11.20: required only for encoding or decoding LZW, JPEG, etc
optdepends = python-lxml>=4.7.1: required only for validating and printing XML
optdepends = python-zarr>=2.10.3: required only for opening zarr storage
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.2.2.tar.gz
- sha256sums = c4ff0ed150803c1dc2ab4b762049c43ea649202b33194309499e1edfee9523b9
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.2.9.tar.gz
+ sha256sums = 7eda74117643681bb2caa695b48f39e2243b4887f7cf991d5adffd813e5c8373
pkgname = python-tifffile
diff --git a/PKGBUILD b/PKGBUILD
index 6f2bbede31d4..6e474f92b3c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2022.2.2
+pkgver=2022.2.9
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -10,6 +10,7 @@ arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
makedepends=('python-setuptools')
+#makedepends=('python-setuptools' 'python-wheel' 'python-build' 'python-installer')
depends=('python-numpy>=1.21.5')
optdepends=('python-matplotlib>=3.4.3: required only for plotting'
'python-imagecodecs>=2021.11.20: required only for encoding or decoding LZW, JPEG, etc'
@@ -17,12 +18,13 @@ optdepends=('python-matplotlib>=3.4.3: required only for plotting'
'python-zarr>=2.10.3: required only for opening zarr storage')
checkdepends=('python-pytest' 'python-fsspec')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('c4ff0ed150803c1dc2ab4b762049c43ea649202b33194309499e1edfee9523b9')
+sha256sums=('7eda74117643681bb2caa695b48f39e2243b4887f7cf991d5adffd813e5c8373')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
+# python -m build --wheel --no-isolation
}
check() {
@@ -39,8 +41,7 @@ check() {
--deselect=tests/test_tifffile.py::test_write_ome_manual \
--deselect=tests/test_tifffile.py::test_write_3gb \
--deselect=tests/test_tifffile.py::test_write_bigtiff \
- --deselect=tests/test_tifffile.py::test_write_imagej_raw \
- --deselect=tests/test_tifffile.py::test_write_predictor || warning "Tests failed"
+ --deselect=tests/test_tifffile.py::test_write_imagej_raw || warning "Tests failed"
}
package() {
@@ -48,7 +49,10 @@ package() {
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 examples/* -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
+
python setup.py install --root="${pkgdir}" --optimize=1
+# python -m installer --destdir="${pkgdir}" dist/*.whl
}
# vim:ts=2:sw=2:et: