summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-02-04 12:57:07 +0800
committerUniversebenzene2022-02-04 12:57:07 +0800
commit74bee03c1bc2a074a1ccf5f643b677a503623a3c (patch)
tree0dd2cd792d715fce2530846c0b62ccba47e772d7
parent8f36c880a39d7a0d3846fe80b0a7a39480a49702 (diff)
downloadaur-74bee03c1bc2a074a1ccf5f643b677a503623a3c.tar.gz
Update to version 2022.2.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6423395c87e8..34ce213285d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2021.11.2
+ pkgver = 2022.2.2
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -8,12 +8,12 @@ pkgbase = python-tifffile
checkdepends = python-pytest
checkdepends = python-fsspec
makedepends = python-setuptools
- depends = python-numpy>=1.21
+ depends = python-numpy>=1.21.5
optdepends = python-matplotlib>=3.4.3: required only for plotting
- optdepends = python-imagecodecs>=2021.8.26: required only for encoding or decoding LZW, JPEG, etc
- optdepends = python-lxml>=4.6.3: required only for validating and printing XML
- optdepends = python-zarr>=2.6.1: required only for opening zarr storage
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2021.11.2.tar.gz
- sha256sums = 153e31fa1d892f482fabb2ae9f2561fa429ee42d01a6f67e58cee13637d9285b
+ optdepends = python-imagecodecs>=2021.11.20: required only for encoding or decoding LZW, JPEG, etc
+ optdepends = python-lxml>=4.7.1: required only for validating and printing XML
+ optdepends = python-zarr>=2.10.3: required only for opening zarr storage
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.2.2.tar.gz
+ sha256sums = c4ff0ed150803c1dc2ab4b762049c43ea649202b33194309499e1edfee9523b9
pkgname = python-tifffile
diff --git a/PKGBUILD b/PKGBUILD
index e6193b70bb1b..6f2bbede31d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2021.11.2
+pkgver=2022.2.2
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -10,14 +10,14 @@ arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
makedepends=('python-setuptools')
-depends=('python-numpy>=1.21')
+depends=('python-numpy>=1.21.5')
optdepends=('python-matplotlib>=3.4.3: required only for plotting'
- 'python-imagecodecs>=2021.8.26: required only for encoding or decoding LZW, JPEG, etc'
- 'python-lxml>=4.6.3: required only for validating and printing XML'
- 'python-zarr>=2.6.1: required only for opening zarr storage')
+ 'python-imagecodecs>=2021.11.20: required only for encoding or decoding LZW, JPEG, etc'
+ 'python-lxml>=4.7.1: required only for validating and printing XML'
+ 'python-zarr>=2.10.3: required only for opening zarr storage')
checkdepends=('python-pytest' 'python-fsspec')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('153e31fa1d892f482fabb2ae9f2561fa429ee42d01a6f67e58cee13637d9285b')
+sha256sums=('c4ff0ed150803c1dc2ab4b762049c43ea649202b33194309499e1edfee9523b9')
build() {
cd ${srcdir}/${_pyname}-${pkgver}