summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-04-09 00:40:46 +0800
committerUniversebenzene2022-04-09 00:40:46 +0800
commit8acec16aa1910190cf4026a21418435c8991c974 (patch)
tree624bd2abac8eb1ce7f52771c4400071d8f22747e
parent1b1391f7172f3765618ac733f2664ec2f78150bb (diff)
downloadaur-8acec16aa1910190cf4026a21418435c8991c974.tar.gz
Update to version 2022.4.8
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26b70968bed8..788897a6c53c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2022.3.25
+ pkgver = 2022.4.8
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
license = BSD
checkdepends = python-pytest
+ checkdepends = python-xarray
checkdepends = python-fsspec
makedepends = python-setuptools
depends = python-numpy>=1.21.5
@@ -13,7 +14,7 @@ pkgbase = python-tifffile
optdepends = python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc
optdepends = python-lxml>=4.8.0: required only for validating and printing XML
optdepends = python-zarr>=2.11.1: required only for opening zarr storage
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.3.25.tar.gz
- sha256sums = 6d943f2c01b1a34a476c963d119565fba108f559e061426c63a5157846959ed9
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.4.8.tar.gz
+ sha256sums = d4a4057e5cb7afe6e24cf7bde42a163970b593afe44c17249894ede755cf3faa
pkgname = python-tifffile
diff --git a/PKGBUILD b/PKGBUILD
index 1b1eb7bee419..68ab845dcd7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2022.3.25
+pkgver=2022.4.8
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -16,9 +16,9 @@ optdepends=('python-matplotlib>=3.4.3: required only for plotting'
'python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc'
'python-lxml>=4.8.0: required only for validating and printing XML'
'python-zarr>=2.11.1: required only for opening zarr storage')
-checkdepends=('python-pytest' 'python-fsspec')
+checkdepends=('python-pytest' 'python-xarray' 'python-fsspec')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('6d943f2c01b1a34a476c963d119565fba108f559e061426c63a5157846959ed9')
+sha256sums=('d4a4057e5cb7afe6e24cf7bde42a163970b593afe44c17249894ede755cf3faa')
build() {
cd ${srcdir}/${_pyname}-${pkgver}