summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-06-22 20:04:14 +0800
committerUniversebenzene2020-06-22 20:04:14 +0800
commitb3023413abf38ed810cf72f3cf9585efd0f6182e (patch)
tree6a04b0534c9d1052c716ac4c736e5f694d5a7c42
parent9c0f9ee05e95322a14439a25dac31d089d315ede (diff)
downloadaur-b3023413abf38ed810cf72f3cf9585efd0f6182e.tar.gz
Update to version 2020.6.3
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD35
3 files changed, 39 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84ee3a466c26..03a003fd8d8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2019.2.10
+ pkgver = 2020.6.3
pkgrel = 1
- url = https://pypi.python.org/pypi/tifffile
+ url = https://github.com/cgohlke/tifffile
arch = any
license = BSD
makedepends = python-setuptools
- depends = python
- source = https://files.pythonhosted.org/packages/8d/5d/8c93c6236ba7d54f79fdec15d3b9ed32b5e2c48b5c4838a5240893b70908/tifffile-2019.2.10.tar.gz
- sha256sums = ead5f84c0b100f8100377b8ef2bcffaf21c249784ddc240346b715408b45f42c
+ depends = python-numpy
+ optdepends = python-matplotlib: required only for plotting
+ optdepends = python-imagecodecs: required only for encoding or decoding LZW, JPEG, etc.
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2020.6.3.tar.gz
+ sha256sums = e79403a8b98b0df7ade8d43469151b959fd56239001471fac62beabca6f56377
pkgname = python-tifffile
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e896dcd6056d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index ced7782a3b52..e1040cc1b072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,40 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
# Contributor: Francois Boulogne <fboulogne at april dot org>
-# Maintainer: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2019.2.10
-_name=tifffile
+pkgver=2020.6.3
+_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
arch=('any')
-url="https://pypi.python.org/pypi/tifffile"
+url="https://github.com/cgohlke/tifffile"
license=('BSD')
-depends=('python')
makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/8d/5d/8c93c6236ba7d54f79fdec15d3b9ed32b5e2c48b5c4838a5240893b70908/tifffile-2019.2.10.tar.gz)
-sha256sums=('ead5f84c0b100f8100377b8ef2bcffaf21c249784ddc240346b715408b45f42c')
+depends=('python-numpy')
+optdepends=('python-matplotlib: required only for plotting'
+ 'python-imagecodecs: required only for encoding or decoding LZW, JPEG, etc.')
+#checkdepends=('python-pytest')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+sha256sums=('e79403a8b98b0df7ade8d43469151b959fd56239001471fac62beabca6f56377')
build() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
}
+#check() {
+# cd ${srcdir}/${_pyname}-${pkgver}
+#
+# PYTHONPATH="build/lib" pytest
+#}
+
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}
# vim:ts=2:sw=2:et: