summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-11-03 13:34:07 +0800
committerUniversebenzene2021-11-03 13:34:07 +0800
commitd6e19126fd3d25d54db7be1c93761f3957b5d1bd (patch)
treec3ec727caf82931f75b268c0f42634d1853908f5
parent89692792a9e90f52fee0fa4ddbdb8748327d1d5e (diff)
downloadaur-d6e19126fd3d25d54db7be1c93761f3957b5d1bd.tar.gz
Update to version 2021.11.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfa797d3ca54..abbce9398360 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2021.10.12
+ pkgver = 2021.11.2
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
license = BSD
makedepends = python-setuptools
- depends = python-numpy>=1.20.3
+ depends = python-numpy>=1.21
optdepends = python-matplotlib>=3.4.3: required only for plotting
optdepends = python-imagecodecs>=2021.8.26: required only for encoding or decoding LZW, JPEG, etc
optdepends = python-lxml>=4.6.3: required only for validating and printing XML
optdepends = python-zarr>=2.6.1: required only for opening zarr storage
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2021.10.12.tar.gz
- sha256sums = 0a78268a2d844af94929512d28b39bd1ea6fe46de4124103840b5fe4e1c555cd
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2021.11.2.tar.gz
+ sha256sums = 153e31fa1d892f482fabb2ae9f2561fa429ee42d01a6f67e58cee13637d9285b
pkgname = python-tifffile
diff --git a/PKGBUILD b/PKGBUILD
index 3a573ede4c0c..819b8d73e12c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2021.10.12
+pkgver=2021.11.2
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -10,14 +10,14 @@ arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
makedepends=('python-setuptools')
-depends=('python-numpy>=1.20.3')
+depends=('python-numpy>=1.21')
optdepends=('python-matplotlib>=3.4.3: required only for plotting'
'python-imagecodecs>=2021.8.26: required only for encoding or decoding LZW, JPEG, etc'
'python-lxml>=4.6.3: required only for validating and printing XML'
'python-zarr>=2.6.1: required only for opening zarr storage')
#checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('0a78268a2d844af94929512d28b39bd1ea6fe46de4124103840b5fe4e1c555cd')
+sha256sums=('153e31fa1d892f482fabb2ae9f2561fa429ee42d01a6f67e58cee13637d9285b')
build() {
cd ${srcdir}/${_pyname}-${pkgver}