summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-08-15 09:41:30 +0800
committerUniversebenzene2020-08-15 09:41:30 +0800
commitd8436811110347b7d7fd0994e5510195d04d732e (patch)
treef272aa9e3f736857f77015fcf4562137d9335069
parent02aeacf9da0970a6b2ba76855efc8e2503a76271 (diff)
downloadaur-d8436811110347b7d7fd0994e5510195d04d732e.tar.gz
Update to version 2020.8.13
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac801fc26daf..1d12d6020914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2020.7.24
+ pkgver = 2020.8.13
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
license = BSD
makedepends = python-setuptools
- depends = python-numpy>=1.15.1
- optdepends = python-matplotlib>=3.1: required only for plotting
- optdepends = python-imagecodecs>=2020.2.18: required only for encoding or decoding LZW, JPEG, etc
+ depends = python-numpy>=1.18.5
+ optdepends = python-matplotlib>=3.2.2: required only for plotting
+ optdepends = python-imagecodecs>=2020.5.30: required only for encoding or decoding LZW, JPEG, etc
optdepends = python-lxml: required only for validating and printing XML
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2020.7.24.tar.gz
- sha256sums = cd8549d6f0742c3c95a856744a26064a1aad1c132fbab95dc9e5dce891a62c17
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2020.8.13.tar.gz
+ sha256sums = 60043e50adab5a1b9f13c3fb1a23992b9af00e1ada13d7ffe48c1ad7e0062cb8
pkgname = python-tifffile
diff --git a/PKGBUILD b/PKGBUILD
index 865c1621ef76..b66a518c7b2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-tifffile
-pkgver=2020.7.24
+pkgver=2020.8.13
_pyname=${pkgname#python-}
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
@@ -10,13 +10,13 @@ arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
makedepends=('python-setuptools')
-depends=('python-numpy>=1.15.1')
-optdepends=('python-matplotlib>=3.1: required only for plotting'
- 'python-imagecodecs>=2020.2.18: required only for encoding or decoding LZW, JPEG, etc'
+depends=('python-numpy>=1.18.5')
+optdepends=('python-matplotlib>=3.2.2: required only for plotting'
+ 'python-imagecodecs>=2020.5.30: required only for encoding or decoding LZW, JPEG, etc'
'python-lxml: required only for validating and printing XML')
#checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('cd8549d6f0742c3c95a856744a26064a1aad1c132fbab95dc9e5dce891a62c17')
+sha256sums=('60043e50adab5a1b9f13c3fb1a23992b9af00e1ada13d7ffe48c1ad7e0062cb8')
build() {
cd ${srcdir}/${_pyname}-${pkgver}