summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-07-29 12:10:51 +0800
committerUniversebenzene2022-07-29 12:10:51 +0800
commitf1f47fef0dff5626595b60acd019c69524721ccf (patch)
tree1d3e54a846c4d4cbd8c52061ade233176d54ab25
parent16a0c6165c52958110fbd0bda564c7346ef6b0fc (diff)
downloadaur-f1f47fef0dff5626595b60acd019c69524721ccf.tar.gz
Update to version 2022.7.28
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 38 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb3c548da718..f6b8c77bde68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2022.5.4
+ pkgver = 2022.7.28
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -9,12 +9,17 @@ pkgbase = python-tifffile
checkdepends = python-xarray
checkdepends = python-fsspec
makedepends = python-setuptools
+ makedepends = python-sphinx
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.7.28.tar.gz
+ sha256sums = 61e3638e35156751dbc3cdbd0e4cf1166b90597d5d1972d03945a96570f1ad81
+
+pkgname = python-tifffile
depends = python-numpy>=1.21.5
- optdepends = python-matplotlib>=3.4.3: required only for plotting
+ optdepends = python-matplotlib>=3.5.2: required only for plotting
optdepends = python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc
- optdepends = python-lxml>=4.8.0: required only for validating and printing XML
+ optdepends = python-lxml>=4.9.1: required only for validating and printing XML
optdepends = python-zarr>=2.11.3: required only for opening zarr storage
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2022.5.4.tar.gz
- sha256sums = b03147a15862b7c1d90d47435197f149bef7a52c25ad67cf1f9b465faa71b8d2
+ optdepends = python-tifffile-doc: Documentation for Python tifffile
-pkgname = python-tifffile
+pkgname = python-tifffile-doc
+ pkgdesc = Documentation for Python Photutils module
diff --git a/PKGBUILD b/PKGBUILD
index 5393c4c6923a..9a3d9d9c1d75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
# Contributor: Francois Boulogne <fboulogne at april dot org>
-pkgname=python-tifffile
-pkgver=2022.5.4
-_pyname=${pkgname#python-}
+pkgbase=python-tifffile
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}" "python-${_pyname}-doc")
+pkgver=2022.7.28
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
arch=('any')
url="https://github.com/cgohlke/tifffile"
license=('BSD')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools'
+ 'python-sphinx')
#makedepends=('python-setuptools' 'python-wheel' 'python-build' 'python-installer')
-depends=('python-numpy>=1.21.5')
-optdepends=('python-matplotlib>=3.4.3: required only for plotting'
- 'python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc'
- 'python-lxml>=4.8.0: required only for validating and printing XML'
- 'python-zarr>=2.11.3: required only for opening zarr storage')
checkdepends=('python-pytest' 'python-xarray' 'python-fsspec')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('b03147a15862b7c1d90d47435197f149bef7a52c25ad67cf1f9b465faa71b8d2')
+sha256sums=('61e3638e35156751dbc3cdbd0e4cf1166b90597d5d1972d03945a96570f1ad81')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
# python -m build --wheel --no-isolation
+
+ msg "Building Docs"
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+# PYTHONPATH="../build/lib" make html
+ PYTHONPATH="../build/lib" python make.py
}
check() {
@@ -44,7 +46,13 @@ check() {
--deselect=tests/test_tifffile.py::test_write_imagej_raw || warning "Tests failed"
}
-package() {
+package_python-tifffile() {
+ depends=('python-numpy>=1.21.5')
+ optdepends=('python-matplotlib>=3.5.2: required only for plotting'
+ 'python-imagecodecs>=2022.2.22: required only for encoding or decoding LZW, JPEG, etc'
+ 'python-lxml>=4.9.1: required only for validating and printing XML'
+ 'python-zarr>=2.11.3: required only for opening zarr storage'
+ 'python-tifffile-doc: Documentation for Python tifffile')
cd ${srcdir}/${_pyname}-${pkgver}
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
@@ -55,4 +63,11 @@ package() {
# python -m installer --destdir="${pkgdir}" dist/*.whl
}
-# vim:ts=2:sw=2:et:
+package_python-tifffile-doc() {
+ pkgdesc="Documentation for Python Photutils module"
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../LICENSE
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+}