summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-09-15 12:28:02 +0200
committerPhilipp A2022-09-15 12:28:02 +0200
commitabfba73513ec2fd16f468318a05f1b9656e5199e (patch)
tree41dde601a90f90ec7c1fb0c46b4b448d424bc2fe
parentfea9e9ff8cce3afbc527ebe795bc39b3d615190c (diff)
downloadaur-python-tikzplotlib-git.tar.gz
deps
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff717b35cddd..3898fcfeaae0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = python-tikzplotlib-git
pkgdesc = Convert matplotlib figures into TikZ/PGFPlots
- pkgver = 0.9.16.r2.g1e30229
- pkgrel = 3
- url = https://github.com/nschloe/tikzplotlib
+ pkgver = 0.10.1.r2.g450712b
+ pkgrel = 1
+ url = https://github.com/texworld/tikzplotlib
arch = any
license = MIT
makedepends = git
+ makedepends = python-flit-core
makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-matplotlib
depends = python-numpy
depends = python-pillow
- provides = python-tikzplotlib=0.9.16.r2.g1e30229
+ depends = python-webcolors
+ provides = python-tikzplotlib=0.10.1.r2.g450712b
conflicts = python-matplotlib2tikz
conflicts = python-tikzplotlib
replaces = python-matplotlib2tikz
- source = tikzplotlib::git+https://github.com/nschloe/tikzplotlib.git
+ source = tikzplotlib::git+https://github.com/texworld/tikzplotlib.git
sha256sums = SKIP
pkgname = python-tikzplotlib-git
diff --git a/.gitignore b/.gitignore
index bd122a328faf..6e96c4e10c4a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
/tikzplotlib/
-/*.pkg.tar.xz
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 0abddd6b13d3..736343d2b861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=python-tikzplotlib-git
-pkgver=0.9.16.r2.g1e30229
-pkgrel=3
+pkgver=0.10.1.r2.g450712b
+pkgrel=1
pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
-url="https://github.com/nschloe/tikzplotlib"
-makedepends=(git python-build)
-depends=(python python-matplotlib python-numpy python-pillow)
+url="https://github.com/texworld/tikzplotlib"
+makedepends=(git python-flit-core python-build python-installer python-wheel)
+depends=(python python-matplotlib python-numpy python-pillow python-webcolors)
provides=("python-tikzplotlib=$pkgver")
conflicts=(python-matplotlib2tikz python-tikzplotlib)
replaces=(python-matplotlib2tikz)
@@ -21,15 +21,11 @@ pkgver() {
build() {
cd "$srcdir/tikzplotlib"
- python -m build
+ python -m build --wheel --no-isolation
}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
-
cd "$srcdir/tikzplotlib"
- local cleanver="$(git describe --tags --abbrev=0 | sed 's/^v//')"
- unzip "dist/tikzplotlib-$cleanver-py3-none-any.whl" -d "$site"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}