summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2019-01-30 22:44:17 +0100
committerSophie Tauchert2019-01-30 22:44:17 +0100
commit6c596057c146b2097381c2e5574344972725d06e (patch)
treee6a6f141781e06a9116fa03fdba2f6b46de0044c
downloadaur-6c596057c146b2097381c2e5574344972725d06e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef5aa25284a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-py3nvml
+ pkgdesc = Bindings for NVML library.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/fbcotter/py3nvml
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = nvidia
+ source = https://files.pythonhosted.org/packages/source/p/py3nvml/py3nvml-0.2.2.tar.gz
+ sha256sums = 647c0131368d0bdb1d1796d3e10651240bae2c0cc89d193d19a6dccc1a81781d
+
+pkgname = python-py3nvml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf692b77363f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+
+_pkgname=timeago
+pkgname=python-${_pkgname}
+pkgver=1.0.8
+pkgrel=1
+pkgdesc="Very simple python library, used to format datetime with \`***time ago\` statement."
+arch=('any')
+url="https://github.com/hustcc/timeago"
+license=('MIT')
+depends=()
+makedepends=('python-pip')
+provides=()
+source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver-py2.py3-none-any.whl")
+sha256sums=('f2acf144a9aabbc1e46a7f84387e6dd17bf41ff5fd87822c878621d06ef6b77c')
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+}