summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2019-02-01 10:36:14 +0100
committerSophie Tauchert2019-02-01 10:36:14 +0100
commit93919bf0d5929b5f097bad7f70598026873514e9 (patch)
tree96ba73187551d623f81b2b4d592e1f0f08785ac3
parent0f183745facdb7ec9064d596f696fede270aedaa (diff)
downloadaur-93919bf0d5929b5f097bad7f70598026873514e9.tar.gz
Update to 1.0.9, Add LICENSE, Use source instead of wheel
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf692b77363f..89ec6fbb443c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,27 @@
_pkgname=timeago
pkgname=python-${_pkgname}
-pkgver=1.0.8
+pkgver=1.0.9
pkgrel=1
pkgdesc="Very simple python library, used to format datetime with \`***time ago\` statement."
arch=('any')
url="https://github.com/hustcc/timeago"
license=('MIT')
-depends=()
-makedepends=('python-pip')
+depends=('python')
+makedepends=('python-setuptools')
provides=()
-source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver-py2.py3-none-any.whl")
-sha256sums=('f2acf144a9aabbc1e46a7f84387e6dd17bf41ff5fd87822c878621d06ef6b77c')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/hustcc/timeago/${pkgver}/LICENSE")
+sha256sums=('5473b95e6232c902b0390f0e44375863f9359432711dbcbbd15033612dc44f8a'
+ 'e2a15cd0b56cfffbb99e27caeb87afe58ff78097d9c3bd3aea2a251145479912')
+
+build() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py build
+}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${_pkgname}-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}