summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2022-08-19 13:50:09 +0200
committerSophie Tauchert2022-08-19 13:50:09 +0200
commitcccabb34993c6ee69f7c4edd6d675807cb689739 (patch)
treebc9f14555a2aa5c7aef99bc07e526c33008b32b4
parent3f4905c6574421064424dcc87769c9ce33f6ead1 (diff)
downloadaur-cccabb34993c6ee69f7c4edd6d675807cb689739.tar.gz
Update to v1.0.16
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7ef207bce44..49921b715e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-timeago
pkgdesc = Very simple python library, used to format datetime with `***time ago` statement.
- pkgver = 1.0.15
+ pkgver = 1.0.16
pkgrel = 1
url = https://github.com/hustcc/timeago
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-installer
depends = python
- source = https://files.pythonhosted.org/packages/source/t/timeago/timeago-1.0.15.tar.gz
- source = https://raw.githubusercontent.com/hustcc/timeago/1.0.15/LICENSE
- sha256sums = cfce420d82892af6b2439d0f69eeb3e876bbeddab6670c3c88ebf7676407bf4c
+ source = https://files.pythonhosted.org/packages/py3/t/timeago/timeago-1.0.16-py3-none-any.whl
+ source = https://raw.githubusercontent.com/hustcc/timeago/1.0.16/LICENSE
+ sha256sums = 9b8cb2e3102b329f35a04aa4531982d867b093b19481cfbb1dac7845fa2f79b0
sha256sums = e2a15cd0b56cfffbb99e27caeb87afe58ff78097d9c3bd3aea2a251145479912
pkgname = python-timeago
diff --git a/PKGBUILD b/PKGBUILD
index d22903de3c16..5dd58cf4b955 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,22 @@
_pkgname=timeago
pkgname=python-${_pkgname}
-pkgver=1.0.15
+pkgver=1.0.16
pkgrel=1
pkgdesc="Very simple python library, used to format datetime with \`***time ago\` statement."
arch=('any')
url="https://github.com/hustcc/timeago"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-installer')
provides=()
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+# use wheel distribution directly as no source distribution is available
+source=("https://files.pythonhosted.org/packages/py3/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}-py3-none-any.whl"
"https://raw.githubusercontent.com/hustcc/timeago/${pkgver}/LICENSE")
-sha256sums=('cfce420d82892af6b2439d0f69eeb3e876bbeddab6670c3c88ebf7676407bf4c'
+sha256sums=('9b8cb2e3102b329f35a04aa4531982d867b093b19481cfbb1dac7845fa2f79b0'
'e2a15cd0b56cfffbb99e27caeb87afe58ff78097d9c3bd3aea2a251145479912')
-build() {
- cd "${_pkgname}-$pkgver"
- python setup.py build
-}
-
package() {
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- cd "${_pkgname}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" "${_pkgname}-${pkgver}-py3-none-any.whl"
}