summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:29:06 -0700
committerAaron DeVore2015-07-08 11:29:06 -0700
commitc252456f8d756a9beb8d47ae2492d571a84c0e24 (patch)
tree09f451c8c18e4d9eef77ef488225b492b9defeeb
downloadaur-c252456f8d756a9beb8d47ae2492d571a84c0e24.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbcb1ac76238
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-timelib
+ pkgdesc = A library to parse english textual date descriptions [Python 3]
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/timelib
+ arch = i686
+ arch = x86_64
+ license = PHP
+ license = custom
+ depends = python
+ source = http://pypi.python.org/packages/source/t/timelib/timelib-0.2.4.zip
+ md5sums = 400e316f81001ec0842fa9b2cef5ade9
+
+pkgname = python-timelib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c80c792c9b95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
+
+pkgname=python-timelib
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="A library to parse english textual date descriptions [Python 3]"
+arch=('i686' 'x86_64')
+url="http://pypi.python.org/pypi/timelib"
+license=(PHP custom)
+depends=('python')
+source=("http://pypi.python.org/packages/source/t/timelib/timelib-$pkgver.zip")
+md5sums=('400e316f81001ec0842fa9b2cef5ade9')
+
+build() {
+ cd "$srcdir/timelib-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package() {
+ cd "$srcdir/timelib-$pkgver"
+ install -D -m644 README.rst \
+ "$pkgdir/usr/share/licenses/$pkgname/README.rst"
+}