summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorY7n05h2022-01-23 22:17:15 +0800
committerY7n05h2022-01-23 22:17:15 +0800
commitaf2f9740d01d0c6694428d3d2eb8fbf3f5477daf (patch)
tree8bd830bea47607a86afe5c1c393495bdc5a338fe
downloadaur-af2f9740d01d0c6694428d3d2eb8fbf3f5477daf.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bad8b58993c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-timeslot
+ pkgdesc = Time slots/intervals with an arbitrary start and stop
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/ErikBjare/timeslot
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-timeslot
+ source = https://pypi.org/packages/source/t/timeslot/timeslot-0.1.2.tar.gz
+ sha256sums = a2ac998657e3f3b9ca928757b4906add2c05390c5fc14ed792bb9028d08547b1
+
+pkgname = python-timeslot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f298abe991d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Y7n05h <Y7n05h(aT)protonmail--d0t--com>
+pkgname=python-timeslot
+_name=${pkgname#python-}
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Time slots/intervals with an arbitrary start and stop"
+arch=('any')
+url="https://github.com/ErikBjare/timeslot"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provides=($pkgname)
+conflicts=()
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a2ac998657e3f3b9ca928757b4906add2c05390c5fc14ed792bb9028d08547b1')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+}