summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Pożarlik2021-01-07 10:33:36 +0100
committerŁukasz Pożarlik2021-01-07 10:33:36 +0100
commit5814475ff899039a0031ae42ed3033f31a50171c (patch)
tree90e30ccd14357e1f5bc070f7dcecc5adf9020ae0
parent66d656f7913d71ccc304b511a74f1e21d6f9ccf5 (diff)
downloadaur-5814475ff899039a0031ae42ed3033f31a50171c.tar.gz
Update to 4.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--python3.patch11
3 files changed, 6 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0a2fa717504..38ef23f4bbc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = python-timezonefinder
pkgdesc = Fast and lightweight project for looking up the timezone for a given lat/lng
- pkgver = 4.1.0
+ pkgver = 4.5.0
pkgrel = 1
url = https://github.com/MrMinimal64/timezonefinder
arch = any
license = MIT
makedepends = python
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-4.1.0.tar.gz
- source = python3.patch
- sha256sums = 0569558a0343e5c0ff6a6d92dc30725ddedec13b6b57fa642c70121dd33496a3
- sha256sums = 2fc4a9ecc413c09c4eddfbfe8c71952d9b7e608f415f3d8ba295988e30786288
+ source = https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-4.5.0.tar.gz
+ sha256sums = 99b0cea5abf304e8738ecf5cceae0c0e5182534843f19638a26a220fa212fbad
pkgname = python-timezonefinder
depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 1104084a382f..8d3a79ec99f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,21 @@
pkgname=('python-timezonefinder')
pkgdesc="Fast and lightweight project for looking up the timezone for a given lat/lng"
-pkgver=4.1.0
+pkgver=4.5.0
pkgrel=1
url="https://github.com/MrMinimal64/timezonefinder"
license=('MIT')
arch=('any')
makedepends=('python'
'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-${pkgver}.tar.gz"
-"python3.patch")
-sha256sums=('0569558a0343e5c0ff6a6d92dc30725ddedec13b6b57fa642c70121dd33496a3'
- '2fc4a9ecc413c09c4eddfbfe8c71952d9b7e608f415f3d8ba295988e30786288')
+source=("https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-${pkgver}.tar.gz")
+sha256sums=('99b0cea5abf304e8738ecf5cceae0c0e5182534843f19638a26a220fa212fbad')
build() {
cp -r ${srcdir}/timezonefinder-${pkgver} ${srcdir}/timezonefinder-${pkgver}-py2
cd ${srcdir}/timezonefinder-${pkgver}
python setup.py build
-
- patch -p1 -i "${srcdir}/python3.patch"
-
- cd ${srcdir}/timezonefinder-${pkgver}-py2
- python2 setup.py build
}
package_python-timezonefinder() {
diff --git a/python3.patch b/python3.patch
deleted file mode 100644
index 18539bf67c47..000000000000
--- a/python3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- timezonefinder-4.0.2/timezonefinder/timezonefinder.py 2019-05-19 13:03:23.032195742 +0200
-+++ timezonefinder-4.0.2/timezonefinder/timezonefinder.py 2019-05-19 13:03:35.232238756 +0200
-@@ -6,7 +6,7 @@
- from struct import unpack
-
- import numpy as np
--from importlib_resources import open_binary
-+from importlib.resources import open_binary
- from numpy import array, dtype, empty, fromfile
-
- from .global_settings import (