summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Pożarlik2019-12-12 09:22:43 +0100
committerŁukasz Pożarlik2019-12-12 09:22:43 +0100
commit66d656f7913d71ccc304b511a74f1e21d6f9ccf5 (patch)
treec542894147c4a8e64549cdfe3c1ba7c5c3cc1058
parenta76ad3fbeec1b2abb347461c79497087f8db7a2f (diff)
downloadaur-66d656f7913d71ccc304b511a74f1e21d6f9ccf5.tar.gz
Drop python 2.7 support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 2 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f3785fd13ab..b0a2fa717504 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,6 @@ pkgbase = python-timezonefinder
license = MIT
makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
source = https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-4.1.0.tar.gz
source = python3.patch
sha256sums = 0569558a0343e5c0ff6a6d92dc30725ddedec13b6b57fa642c70121dd33496a3
@@ -17,6 +15,3 @@ pkgbase = python-timezonefinder
pkgname = python-timezonefinder
depends = python-numpy
-pkgname = python2-timezonefinder
- depends = python2-numpy
-
diff --git a/PKGBUILD b/PKGBUILD
index 5b69dedb901c..1104084a382f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Łukasz Pożarlik <lpozarlik@gmail.com>
-pkgname=('python-timezonefinder' 'python2-timezonefinder')
+pkgname=('python-timezonefinder')
pkgdesc="Fast and lightweight project for looking up the timezone for a given lat/lng"
pkgver=4.1.0
pkgrel=1
@@ -8,9 +8,7 @@ url="https://github.com/MrMinimal64/timezonefinder"
license=('MIT')
arch=('any')
makedepends=('python'
- 'python-setuptools'
- 'python2'
- 'python2-setuptools')
+ 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-${pkgver}.tar.gz"
"python3.patch")
sha256sums=('0569558a0343e5c0ff6a6d92dc30725ddedec13b6b57fa642c70121dd33496a3'
@@ -35,12 +33,5 @@ package_python-timezonefinder() {
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
-package_python2-timezonefinder() {
- depends=('python2-numpy')
- cd ${srcdir}/timezonefinder-${pkgver}-py2
- python2 setup.py install --prefix=/usr --root=${pkgdir}
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
-}
-
# vim:set ts=2 sw=2 et: