summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Pożarlik2019-05-19 13:21:59 +0200
committerŁukasz Pożarlik2019-05-19 13:21:59 +0200
commit6ecfad333d9b0efab5a617ae76612c487bb44cfd (patch)
treebba991f1c350661fb89f80214c3484099e73e398
parent14b71d447a019ed6c71b6ce11e3df8aea1120113 (diff)
downloadaur-6ecfad333d9b0efab5a617ae76612c487bb44cfd.tar.gz
update to 4.0.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--python3.patch11
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d870e7c1bba..c314d7f657dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-timezonefinder
pkgdesc = Fast and lightweight project for looking up the timezone for a given lat/lng
- pkgver = 3.0.0
+ pkgver = 4.0.2
pkgrel = 1
url = https://github.com/MrMinimal64/timezonefinder
arch = any
@@ -9,8 +9,10 @@ pkgbase = python-timezonefinder
makedepends = python-setuptools
makedepends = python2
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-3.0.0.tar.gz
- sha256sums = 90f19dc51752e51b5e23742b5cb40763844855096f017a07c361eed1377777dd
+ source = https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-4.0.2.tar.gz
+ source = python3.patch
+ sha256sums = 659ff7fe78248e6a79af4652be70f88bc72ed5478985e2c0bbc5e2c1868bf380
+ sha256sums = 2fc4a9ecc413c09c4eddfbfe8c71952d9b7e608f415f3d8ba295988e30786288
pkgname = python-timezonefinder
depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 126728f506f3..c52b3feb697e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-timezonefinder' 'python2-timezonefinder')
pkgdesc="Fast and lightweight project for looking up the timezone for a given lat/lng"
-pkgver=3.0.0
+pkgver=4.0.2
pkgrel=1
url="https://github.com/MrMinimal64/timezonefinder"
license=('MIT')
@@ -11,15 +11,19 @@ makedepends=('python'
'python-setuptools'
'python2'
'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-${pkgver}.tar.gz")
-sha256sums=('90f19dc51752e51b5e23742b5cb40763844855096f017a07c361eed1377777dd')
+source=("https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-${pkgver}.tar.gz"
+"python3.patch")
+sha256sums=('659ff7fe78248e6a79af4652be70f88bc72ed5478985e2c0bbc5e2c1868bf380'
+ '2fc4a9ecc413c09c4eddfbfe8c71952d9b7e608f415f3d8ba295988e30786288')
build() {
cp -r ${srcdir}/timezonefinder-${pkgver} ${srcdir}/timezonefinder-${pkgver}-py2
cd ${srcdir}/timezonefinder-${pkgver}
python setup.py build
-
+
+ patch -p1 -i "${srcdir}/python3.patch"
+
cd ${srcdir}/timezonefinder-${pkgver}-py2
python2 setup.py build
}
diff --git a/python3.patch b/python3.patch
new file mode 100644
index 000000000000..18539bf67c47
--- /dev/null
+++ b/python3.patch
@@ -0,0 +1,11 @@
+--- timezonefinder-4.0.2/timezonefinder/timezonefinder.py 2019-05-19 13:03:23.032195742 +0200
++++ timezonefinder-4.0.2/timezonefinder/timezonefinder.py 2019-05-19 13:03:35.232238756 +0200
+@@ -6,7 +6,7 @@
+ from struct import unpack
+
+ import numpy as np
+-from importlib_resources import open_binary
++from importlib.resources import open_binary
+ from numpy import array, dtype, empty, fromfile
+
+ from .global_settings import (