summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrougnouf (Benoit Brummer)2024-04-02 01:22:35 +0200
committerTrougnouf (Benoit Brummer)2024-04-02 01:22:35 +0200
commitb33dc701326afaa098b5b5678f780f3cb63ea277 (patch)
tree3adc303fa30e124ed62dfc6fe3c609686c94593b
parent9bc7a37fdd61397b5c6836fecdcab25cafe18d9c (diff)
downloadaur-b33dc701326afaa098b5b5678f780f3cb63ea277.tar.gz
update to 6.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aafafb34ad3c..9920d1b65ec6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-timezonefinder
pkgdesc = Fast and lightweight project for looking up the timezone for a given lat/lng
- pkgver = 5.2.0
- pkgrel = 2
+ pkgver = 6.5.0
+ pkgrel = 1
url = https://github.com/MrMinimal64/timezonefinder
arch = any
license = MIT
makedepends = python
+ makedepends = python-numpy
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-5.2.0.tar.gz
- sha256sums = a374570295a8dbd923630ce85f754e52578e288cb0a9cf575834415e84758352
+ makedepends = python-cffi
+ makedepends = python-poetry-core
+ source = https://github.com/jannikmi/timezonefinder/archive/refs/tags/6.5.0.tar.gz
+ sha256sums = d28f633c86a4affb4b47b37ef6dc3339033d705dca27817b9f2ff34027d1c773
pkgname = python-timezonefinder
- depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 0601a21e8959..d63a4593607c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,22 @@
-# Maintainer: Łukasz Pożarlik <lpozarlik@gmail.com>
+# Maintainer: Benoit Brummer (Trougnouf) <trougnouf@gmail.com>
+# Contributor: Łukasz Pożarlik <lpozarlik@gmail.com>
+# Contributor: Nicholas Wang <me AT nicho1as DOT wang>
pkgname=('python-timezonefinder')
pkgdesc="Fast and lightweight project for looking up the timezone for a given lat/lng"
-pkgver=5.2.0
-pkgrel=2
+pkgver=6.5.0
+pkgrel=1
url="https://github.com/MrMinimal64/timezonefinder"
license=('MIT')
arch=('any')
-makedepends=('python'
- 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/t/timezonefinder/timezonefinder-${pkgver}.tar.gz")
-sha256sums=('a374570295a8dbd923630ce85f754e52578e288cb0a9cf575834415e84758352')
+makedepends=('python' 'python-numpy' 'python-build' 'python-installer' 'python-setuptools' 'python-cffi' 'python-poetry-core')
+source=("https://github.com/jannikmi/timezonefinder/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('d28f633c86a4affb4b47b37ef6dc3339033d705dca27817b9f2ff34027d1c773')
build() {
- cp -r ${srcdir}/timezonefinder-${pkgver} ${srcdir}/timezonefinder-${pkgver}-py2
-
- cd ${srcdir}/timezonefinder-${pkgver}
- python setup.py build
+ python -m build --no-isolation --wheel --outdir ${srcdir}/dist/ ${srcdir}/timezonefinder-${pkgver}
}
-package_python-timezonefinder() {
- depends=('python-numpy')
- cd ${srcdir}/timezonefinder-${pkgver}
- python setup.py install --prefix=/usr --root=${pkgdir}
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+package() {
+ python -m installer --destdir="$pkgdir" ${srcdir}/dist/*.whl
}
-
-# vim:set ts=2 sw=2 et:
-