summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2022-06-25 19:01:57 -0700
committerSam2022-06-25 19:02:46 -0700
commit632082ecc749344364064150b6e56b14712c77fd (patch)
tree998f8c966575ebb5bc1699b6ded024831c2495cb
downloadaur-632082ecc749344364064150b6e56b14712c77fd.tar.gz
feat: init python-tinyaes 1.0.3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..280d24ef4cfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-tinyaes
+ pkgdesc = A utility to find python versions on your system.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/naufraghi/tinyaes-py.git
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ depends = cython
+ source = https://files.pythonhosted.org/packages/source/t/tinyaes/tinyaes-1.0.3.tar.gz
+ sha512sums = 71efd4bfcd0b68a883f174b06801dcdcc133f8075530c41d0315e5b60bd9730815a89a1b60acaffdfed403d0f50080afbd20ce1539607d05cb340c743558372f
+ b2sums = 3f73cd7c3c4483292e8d0d61c9b0c3daa1bdd237f497d3ce60c05b5da6b9a9710b29775b944c7ec8e680ad5bc8f0f9870ce2953d4a2468db8ec7ad2e1fb226a8
+
+pkgname = python-tinyaes
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..209eaaefe67f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a78458d82bd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sam <dev at samarthj dot com>
+
+# shellcheck disable=2034,2148,2154
+
+pkgname=python-tinyaes
+_name=${pkgname#python-}
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A utility to find python versions on your system."
+arch=("any")
+url="https://github.com/naufraghi/tinyaes-py.git"
+license=("MIT")
+depends=("cython")
+makedepends=("python-build" "python-installer" "python-setuptools")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('71efd4bfcd0b68a883f174b06801dcdcc133f8075530c41d0315e5b60bd9730815a89a1b60acaffdfed403d0f50080afbd20ce1539607d05cb340c743558372f')
+b2sums=('3f73cd7c3c4483292e8d0d61c9b0c3daa1bdd237f497d3ce60c05b5da6b9a9710b29775b944c7ec8e680ad5bc8f0f9870ce2953d4a2468db8ec7ad2e1fb226a8')
+
+build() {
+ cd "$srcdir/${_name}-$pkgver" || exit 1
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+package() {
+ cd "$srcdir/${_name}-$pkgver" || exit 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 "LICENSE.txt" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -vDm 644 "README.md" -t "$pkgdir/usr/share/doc/$pkgname/"
+}