summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2019-01-25 14:43:03 +0800
committerKaizhao Zhang2019-01-25 14:43:03 +0800
commite33867bd5f5646d3bb1e0a2804e22e18e133027a (patch)
tree7ce5e2f3b3bd53e038eb653d3a6f22ae2a1565af
downloadaur-e33867bd5f5646d3bb1e0a2804e22e18e133027a.tar.gz
Initial import with version 0.1.5
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fc580a3b6c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-tinyrecord
+ pkgdesc = Atomic transactions for TinyDB
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/eugene-eeo/tinyrecord
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ options = !emptydirs
+ source = https://github.com/eugene-eeo/tinyrecord/archive/0.1.5.tar.gz
+ sha256sums = 2875aa34620cf7bfa2c0ba5e8d0c7d92c29efac177f30c6910d017111f505731
+
+pkgname = python-tinyrecord
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a08ba4239d3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_srcname=tinyrecord
+
+pkgname=python-tinyrecord
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Atomic transactions for TinyDB"
+arch=('any')
+url="https://github.com/eugene-eeo/tinyrecord"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=(
+ "https://github.com/eugene-eeo/tinyrecord/archive/${pkgver}.tar.gz"
+)
+sha256sums=(
+ '2875aa34620cf7bfa2c0ba5e8d0c7d92c29efac177f30c6910d017111f505731'
+)
+
+build() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}