summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbiloucat2017-04-17 15:18:17 +0200
committerbiloucat2017-04-17 15:18:17 +0200
commit5fdb1a992875c3b45b51ec992eff21069002f060 (patch)
treed86f302f35bfc984c60d44fd37e1e587872299e2
downloadaur-5fdb1a992875c3b45b51ec992eff21069002f060.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21ceab54444b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Apr 17 12:58:29 UTC 2017
+pkgbase = python-tkencfs-git
+ pkgdesc = EncFS GUI for encrypted directory mounting
+ pkgver = 0.9.r4.gca63f86
+ pkgrel = 1
+ url = https://github.com/biloucat/tkencfs
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python>=3.6
+ depends = tk>=8.6.6
+ source = git+https://github.com/biloucat/tkencfs.git
+ md5sums = SKIP
+
+pkgname = python-tkencfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88b7256d933c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: biloucat <biloucat at gmail dot com>
+
+pkgname=python-tkencfs-git
+_gitname=tkencfs
+pkgver=0.9.r4.gca63f86
+pkgrel=1
+pkgdesc='EncFS GUI for encrypted directory mounting'
+arch=('any')
+url='https://github.com/biloucat/tkencfs'
+license=('GPL3')
+makedepends=('git' 'python-setuptools')
+depends=('python>=3.6' 'tk>=8.6.6')
+
+source=("git+https://github.com/biloucat/tkencfs.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ #cutting off 'v' prefix that presents in the git un-annoted tag
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ # remove egg
+ msg "Remove egg"
+ rm -R $pkgdir/usr/lib
+}