summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-03-09 10:26:24 +0000
committerWill Handley2022-03-09 10:26:24 +0000
commit10c85faa4baecd2da5472b1432d3c3af84b0fb02 (patch)
treebca7a71c8d6ebaf567aba0493c3fd19d763a8192
downloadaur-10c85faa4baecd2da5472b1432d3c3af84b0fb02.tar.gz
version 1.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..350b4ad1ae07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-todoist-api-python
+ pkgdesc = This is the official Python API client for the Todoist REST API.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/Doist/todoist-api-python
+ arch = any
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry
+ depends = python-requests
+ options = !emptydirs
+ source = https://github.com/Doist/todoist-api-python/archive/v1.1.0.tar.gz
+ sha256sums = 177abf9fbbb9f3f7d8cbcebc5ec8e2b37bd9c7e72b7682805d5647bf18b26eb8
+
+pkgname = python-todoist-api-python
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb33dd533528
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=todoist-api-python
+pkgname=python-$_modulename
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="This is the official Python API client for the Todoist REST API."
+arch=(any)
+url="https://github.com/Doist/$_modulename"
+license=('BSD')
+groups=()
+depends=(python-requests)
+makedepends=(python-build python-installer python-poetry)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('177abf9fbbb9f3f7d8cbcebc5ec8e2b37bd9c7e72b7682805d5647bf18b26eb8')
+
+build() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+